Deployer Not Working as Expected

We are receiving various error message while doing the deployment using wM8.2 deployer

Errors are like

  • Unresolved dependance error even ignored dependency option was checked
  • Read timed out error
  • Unable to load the package in node2

Each time we are receiving different types of error. Even restart also doesn’t worked. Can any one help us fix this issue or do we have any fix available.

Try the below troubleshooting:

Check network connectivity between the deployer server and target server. Also, verify that the target Integration Servers are running.

Install the necessary components on the target system, or change the deployer project so that it no longer requires the missing dependencies. The error is normal if there is any missing dependencies.

Can you share the Fix-Level for the Deployer?

Make sure that the WmDeployerResource-Package has the same Fix-Level as the Deployer itself.

I had similar issues in my wM 9.5 Instances, which were solved with a newer Deployer-Fix.



First , Install the latest Fix on Deployer and DeployerResource package.

Try doing the deployment using ocmmand line. If that is working fine. Then it should work fine on UI too.

See if you have enabled proxy or any script in your browser which is causing the timeout error.

Note : The dependency related warnings need to be resolved if they are valid warnings.