Delimiter option in Map editor in Unix platform

We are using Natural on Unix platform. But when editing a map in UNIX platform, the map setting screen does not showing the Delimiters option. Any help on this would be more helpful.

Regards,

Jawahar.A

What do you mean with “Delimiters option”?
The Map-Profile on Windows should be exactly the same as on Unix.
On Windows you get into that profile with Map > Map Profile …
On Unix this is Ops. Map > Prof. Map

I went in to Ops.Map option on Map editor. the following window pop up. but on mainframe, the Delimiters are displayed along with the below.

±-----------------------------------------------------------------------------+
| NATURAL MAP EDITOR (Esc to select field) |
|Cr±Map Settings----------------------------------------------------------+ |
±-|Format Context |—+
|------------------------- ------------------------- |
|Page Size …: 23 |
|Line Size …: 79 WRITE Statement …: N |
|Layout …: |
| dynamic …: N Help Routine …: |
|Zero Print …: N Help Parameter …: |
|Upper Case …: Y as field default .: N |
|Manual Skip …: N Help Text …: N |
|Decimal Char …: . Position Line …: 0 Column : 0 |
|Standard Keys .: N AutoRuleRank …: 1 |
|Right Justify .: Y |

Print Mode …: Filler Characters
Control Var …: Optional, Partial .: _
Required, Partial .: _
Field Sensitive: N Optional, Complete : _
Required, Complete : _

±----------------------------------------------------------------------+

Modify map profile

please let me know why it differs from the mainframe.

regards,
Jawahar.A

Sorry, I cannot answer this question, because I never worked on a mainframe. But there are some people with mainframe-knowledge here is this forum…

But let me give you a hint for your posting:
If you want to post a screendump in this forum, please enclose it in code tags. It looks like this:

[code]This is my code or screendump.
      Here no leading or multiple       spaces are shortened[/code]

The delimiters are relevant on the mainframe because you don’t have a GUI mapping tool there, so the delimiters provide a shorthand convention for associating attributes with the field. They are not needed in the Windows/Unix GUI environments.

Why are you looking for the delimiters? If you want to change the field’s attributes, right-click and select “Definition” or “Colors”. To change a bunch of fields, use shift-click to select the group of fields (convention may be somewhat different on Unix, but there should be some multiple-selection option) and set the colors or whatever.