Defining EDI Document Standard X12 v6042 Set 867 to Trading Networks

I’m trying to define an X12 document (Standard X12 v6042 Set 867) to Trading Networks using the Admin Panel. But there isn’t a selection for v6042. I’ve applied all of the most recent EDI associated fixes, still no luck. Current IS version 8.2.2 and WmEDI package version

Reached out to SAG’s Support Services and was informed that this X12 standard version isn’t supported for any Integration Server.

  • Has anyone else encountered this document definition problem for Trading Networks?
  • Is there another way to properly define an X12 document type to Trading Networks without it being available from the Admin Panel?
  • Has anyone found any alternative solutions?


I don’t think you can do this on your own.
I’d suggest that you try to use the closest version available.
I see: 6020 in the 9.8 installation.


Unfortunately that doesn’t. I specifically need 6042 set 867.

I found the SEFS configuration file in the WmEDI package and thought I could create/modify it for 6042, doesn’t seem like a valid approach. The complexity of the file makes it impossible.

Yes and did you also try to reach out to SAG tech support for the available options and see if they ever or future support this v6042?

And in 9.x I do see X12 v6040 v 6050 but not v6042 are you sure?



Yes, I tried reaching out to SAG’s Support Services and was informed that this X12 standard version isn’t supported for any Integration Server.

I was able to get the document type defined in Trading Networks.

There are assumptions taking into effect:

  1. You have X12 v6040 available.

These are the steps used:
A. Go to IS folder (IntegrationServer\packages\WmEDIforTN\config).
B. Copy file (X12_6040_DocTypes.xml) to (X12_6042_DocTypes.xml).
C. Edit file (X12_6042_DocTypes.xml) and keep only references to X12 6040 867.
D. Change all references of 6040 to 6042.
E. Go to IS folder (IntegrationServer\packages\WmEDI\pub\SEFS\X12).
F. Copy file (6040.SEF) to (6042.SEF).
G. Edit file (6042.SEF). At the top of the file, change 6040 to 6042. Should be two places. Make sure.
H. Later in the file is another reference to 6040. Since you’re adding 6042, you will also need to place 6041 in the sequence. (NOTE: Looking at other SEF files, it’s assumed you need to have 6041 in the sequence.)
I. Start Designer and connect to the IS that you’re modifying.
J. Go to package (WmEDIforTN) and run service (wm.b2b.editn:installEDITypes) with the following inputs (X12 6042 867).
K. Go into Trading Networks console and verify that the document is present and enabled in the list of valid documents.

Now that I’ve been able to define the document into Trading Networks, the issue I’m currently having is parsing the incoming v6042 document from our pipeline partner. Being that this is actually a version of the v6040 document I’m having parsing issues. The file schema & dictionary complexity has made modifying the parse process my next hurdle.

Yes you will see that hurdle for 6042 parsing.

Any work around that SAG suggests for this schema and version?