Debug ForEach Mapping in Designer

I am using webMethods version 10.1 and trying to get the ForEach service working in debug mode. The operation works correctly when I run the service that calls it but I cannot debug the service as I get a java.lang.NullPointerException. That is, I try ‘step over’ on the MAP and get the error

Any suggestions?

I’ve got the latest updates.

I remember in the past that debugging was not enabled on FOREACH mapping when this feature initially added. There was a fix to get it enabled,

Can you share the IS and Designer (Service Development) Fix levels?

The fixes that I have installed are


I ran a debug test on FOREACH mapping and it works fine without any issues, below are my fix levels on IS and Designer:

webMethods Service Development (Fix #5)

Try installing the fixes on your Deisnger and let me know if you still have the same issue.

Okay, I uninstalled WmDesigner_10.1_Fix2 but the problem still occurred, so reverted back to the previous version IS_10.1_Core_Fix7 and I can now debug the service

Thanks for the update, but I would suggest you open an SR with SAG support regarding the IS fix IS_10.1_Core_Fix8.

I am facing the same issue, but on version 10.3

Service Development Plug-in to Designer 10.3 Fix 6
WmDesigner 10.3 Fix1
Integration Server Core 10.3 Fix 3

Service runs normally, but debugging always throw NullPointerException, even if I don’t Step Into the services that contain ForEach mapping.

Any help would be apprecciated

Thanks in advance

This is a bug and it needs to reported to global support. Try uninstalling the latest IS fix if that helps.