dbconfiguratorUI.bat file not working in wM 10.5

Hi All,

I am trying to configure the database for the new IS server after the installation, but the dbconfiguratorUI.bat file is not loading. Even I tried to create the DB using dbconfigurator (cmd) and used the below command but no luck.

Used Command for SQL Server:

dbConfigurator.bat -a create -d SQLServer -c all -v latest -u -p -l jdbc:wm:sqlserver://:1433;databaseName=

Error: I can see the below error in dcc.log file

dcc version: 10.5.0.0000-0169
executing action: create
processing products:
processing components: [all]
error.message: java.sql.SQLInvalidAuthorizationSpecException: [SoftwareAG][SQLServer JDBC Driver][SQLServer]Login failed for user ‘test_actv_is01’.
error.stackTrace: [Ljava.lang.StackTraceElement;@312aa7c

Please suggest, if I am doing something wrong or need to do it differently

  • Could you please share the correct command for 10.5 to update all the components and Integration Server related tables for the SQL server?

Hi Yogeshwar,

unfortunately the GA version of 10.5 did not have a UI version for the DB Configurator.
This was added in a Fix later on.

Please check the documentation section for the Installation and Update Guides.
There should be some information for the right syntax of the comnmand line version.

Regarding your try to use the command line:
Hopefully you have removed the IP and user data from the line for sharing reasons.
Somehow you are using invalid credentials for connecting to your database.

When this is an existing database user and schema you should use “update” instead of “create”.

Regards,
Holger

I know we have the latest fixes available for DB Configurator (DC_10.5_DCC_Fix8) and tried to download the fix file from empower, even tried with SAG Update Manager but it didn’t work for me, looks like to fix all this I think EME should be there with Client and SAG.

For the time being, I just used the command line process using the above command but got the error, actually, it’s a new database user so we have to use create, I have read/write access for this user.

Do we need Super Admin permission for this new DB user or not needed?

I also run the below command as per the 10.5 doc but got the error

If you are creating the new user using dbconfigurator you need super admin privileges; if the user is created properly, you don’t need that. But what I don’t understand is you are trying to create a new IS server, why do you want to create a new DB? Even if you are migrating/updating the db tables because of some later fixes, you still don’t need a new DB unless your new IS instance(s) use(s) a different DB. If you are adding a new IS to a cluster, just set the JDBC drivers to same DB connection string and that’s it.

Can you tell me why you are trying to create a new DB? May be you don’t really need that?

1 Like

Time and again I’ve learned the hard way to trust the error message. :slight_smile: This is indicating login failed. Not a permissions issue Cannot login. Either wrong credentials or connecting to wrong DB?

Hello @engin_arlak

We are setting up a new IS instance for one of the new region and a new DB server as well, so we are done with the installation initially with embedded database but now we are trying to set up the external DB.

DB User is created but trying to create the IS related tables on the new DB servers using dbconfigurator command line process and that’s process is failed.

If anyone can share the correct dbconfigurator command/syntax for 10.5 to create all the components and Integration Server related tables for the SQL server?

Credentials are correct and we are connecting to the right DB as well.

You can install dbconfigurator to your local pc and use it from local if you want. Can you share the logs again if it is still failing?

Also by any chance do you have collation set to a language other then English? This happened to me long ago, sql server’s default setting for case sensitivity is case insensitive. The language my db set to had a different upper and lower cases for letter “i;I” as “i,İ;ı,I”. This caused some of the db functions not to be found. I had to edit db scripts manually to fix this problem. Next time I created another db I set collation to English to avoid this problem.

Another thing to mention, 10.5 is about to be out of support scope. The support will cost more after October if you want to keep using 10.5. If you are moving your environment, it may be a good idea to install the latest version(10.15 now) instead of 10.5.

1 Like

So the error message you shared no longer occurs? Is there a different error message?

Hi All, Thanks for your reply and suggestions, I have reached out to Empower team as I was not able to connect to Empower via the SAG update manager, now they have fixed the issue and I have reset my Empower account pass.

I am able to connect to Empower via SAG Update Manager and able to apply the DC_10.5_DCC_Fix8, after applying the DC fix able to open the dbconfiguratorUI.bat file and created the product tables successfully.

Thanks,
Yogeshwar

2 Likes