Curious Error of WSD not found


I have these error. But I’m very surprised.
on my Designer the wsAvenants WSD does not exist anymore
on my IS Server the wsAvenants folder does not exist

I’ve tried to reload the package that has contained the WSD, and tried to restart my server.

but it is still the same thing :this error still there.
How is it possible please ? (my big problem is it happening in PRODUCTION)


Are you sure no one deleted it manually, (check the logs either server.log or security logs to see for some trace msgs).

Try adding IS extended setting watt.server.http.preserveUriReservedChars=false and restart the IS.

Also access http://host:port/ws will list all WebService deployed, see if you find your WS here.

The error was there before, so I’ve decided to delete the WSD from the Designer.
Once deleted, I can observe in the server files, that the corresponding folder had been deleted too.
At this point all this normal.

But…I still have this error.

I’ve tried to set the paramater, but after having restarted. The error comes again.
I don’t understand “what” still calling this WSD ?

Looking at the URL /ws : the wsAvenants is not present (this is normal, because I’ve deleted it the WSD in the Designer)

Would you have any other idea ?


Hmm… you may ignore that extended setting that I posted earlier.

To know why you see this error can you attach your server.log and error logs to see the logs before this error, based on this we can know what is causing this message to pop up. Also let me know what is the frequency of this messages. I assume it is a consumer WSD is it?

Thanks Maesh.
Regarding deeper I’ve put some logs at TRACE level and can see that the host called is an alias (not the real server name of the IS).
I have to see with our IT Infrastructure manager why this alias is relaying :

[69157]2016-09-23 16:07:09 CEST [ISC.0038.0002D] ← Host:
[69156]2016-09-23 16:07:09 CEST [ISC.0039.0001D] HEAD /ws/wsAvenants?WSDL
[69155]2016-09-23 16:07:08 CEST [ISU.0000.9999D] InfraDC: ISDCNotificationQueue sending isextdc.logmessage to queue
[69154]2016-09-23 16:07:08 CEST [ISU.0000.9999D] InfraDC: Service Error Event null
[69153]2016-09-23 16:07:08 CEST [ISC.0038.0002D] → Content-Length: 331
[69152]2016-09-23 16:07:08 CEST [ISC.0038.0002D] → Content-Type: text/xml; charset=UTF-8
[69151]2016-09-23 16:07:08 CEST [ISC.0038.0002D] → HTTP/1.0 500 [ISS.0088.9163] Could not retrieve WSDL for service wsAvenants, WSD not found.
[69150]2016-09-23 16:07:08 CEST [ISS.0048.9999D] [ISS.0088.9163] Could not retrieve WSDL for service wsAvenants, WSD not found.
[69149]2016-09-23 16:07:08 CEST [ISS.0033.0140T] Session 6b7d81d0e03317c9a8c9fffffffebfa5 - Removed from memory.
[69148]2016-09-23 16:07:08 CEST [ISS.0012.0036D] No user found corresponding to the passed SAML assertion.
[69147]2016-09-23 16:07:08 CEST [ISS.0012.0003T] Client did not provide a session ID. Creating a new session 6b7d81d0e03317c9a8c9fffffffebfa5.
[69146]2016-09-23 16:07:08 CEST [ISS.0033.0140T] Session 6b7d81d0e03317c9a8c9fffffffebfa5 - Created in memory.


Check /etc/host file for the host alias name that you referring. Also as some notes, check if you have any Optimize for Infra monitoring for these services (as I see some msg pertaining to it). Also clean up the end point alias w.r.t to this WSD only.

Good luck! I hope these messages are not blocking your BAU.