Creating Portlet - Cannot find specified default Target Runtime

I am trying to create my first Portlet using 8.2.2. I went to New --> Project --> Software AG -> UI Development -->Portlet Application Project. From there the documentation says the Target Runtime should be “My webMethods Server”. The problem is I do not have this option in the drop down. The only option I have is “”. How do I get this option into the drop down list? I clicked on the “New Runtime…” button but it is not there. I also clicked on the “Download additional server adapters” link but there are webmethods servers to select.

More Information:
In the Target runtime dropdown only “” displays as an option. I clicked the “New Runtime…” button and there are folders for Apache, Basic, IBM, JBOSS, ObjectWeb and Oracle but I assume these are only used if you want to deploy to somwhere other than the webmethods server. I have one option that references web methods which is IBM WebSphere v6.1(for webmethods CAF).

Clicking on the Download Additional Server Adapters has adapters by Apache/OW2/Oracle/SAP/IBM. No Software AG options were retrieved.

Please verify that when you ran the installer to install Designer, that this item was checked: “Designer > Composite Applications > My webMethods Server Support 8.2 SP1”

When that is installed your designer should have a ‘Software AG’ folder in the New Runtime dialog to allow you to use the “My webMethods Server” runtime for your projects in your workspace. Actually, when you open the UI Development perspective in designer, the default MWS sever runtime should automatically be discovered and added automatically for you if it is installed in the expected location.

1 Like

I ran the installer and I don’t see the option "My webmethods Server Support 8.2 SP1. I have attached a screen capture so you can see the options I have and what is installed.

Under Designer --> Composite Applications I have two options

  1. UI Development 8.2 SP1 (Installed)
  2. CentraSite Integration 8.2 SP1 (Installed)
    designer_installer.png

Ok. Well at this point I would suggest contacting your support representative or filing a new support ticket. It looks like the account you are using for the installer does not have permission to view some of the components you will need.

In version 10.1, i had the same problem and it was because during the initial installation not everything including Task Development 10.1 , MY Webmethods Server 10.1 support was not installed.
I ran the install again and selected all components under composite applications and this sorted out the issue.