Corrupt uninstall prevents re-install of ADK...

I uninstalled the ADK evaluation version, it appeared to work fine. I then uninstalled the development kit and the integration server and tried to reinstall everything. The development kit installed fine, the integrationserver installed fine. But, when I go to install the ADK it says that it’s already installed. Any suggestions would be appreciated.


The ADK is available for installation during the webMethods 601 installation using the webMethods Installer.

Thanks for the suggestions, unfortunately, I’m using the evaluation download. The version of this is 4.6 SP1. None of the installs I ran had any option to install the adapter. They have an ADK download installer with the evaluation but that installer indicates that it’s already been installed (after the integration server is installed).

I definitely do not see a WMSampleAdapter. I also do not see the directories described in the adapter tutorial. Any other suggestions would be appreciated.

OK, Look for the following:

Can you run the uninstallADK.exe from this directory?

I have experienced the same problem, except with a first-time installation of the evaluation suite. After installing IS and Developer, the ADK installation fails, indicating that it is already installed. It appears that the earlier installations created a directory /packages/imdk. If I rename this imdk directory, the ADK installation will progress. (I don’t think this is necessarily the correct fix, just an indicator of the problem).

Thanks for your help - this worked!