Controller HTTP Port for WM Optimize


While Installing WM Optimize, I have given the default port 8080 for the Controller HTTP Port. After installation and configuring DB for Optimize When I try to check the WM BAM Controller through http:\\localhost:8080 I was not getting the BAM Screen.

I checked whether the webMethods BAM Controller & PopChart_Server40 is running. Both the services are running and even I was able to see the POPChart screen thru http:\\localhost:2001.

Our LAN is configured to a Proxy server through the port 8080. Will it be the reason for not getting the BAM Screen even BAM Controller is running?

Can I configure the Controller HTTP Port to different port other than default port 8080? Is it possible to change the Controller HTTP Port now<after>? How can I do that? Pls help me in this.

Thanks & Regards

Hi Ravidran,
First of all your LAN proxy settings have nothing to do with Optimize COntroller port 8080. I have same port being used in my LAN and it never gives any problem.

Secondly try using ur HOSTNAME or IP rather LOCALHOST. it might work.

Thirdly, rather than Starting Optimize from SERVICES, try starting them from command line which will give you details in case there is some other reason for failing.

Fourthly You can always change the port of Controller in STATION.PROPERTIES file from <controller\conf\local\station>

But in that case make sure that Satellite are not getting distured due to change in this port.

If in case you are facing any other problem then feel free to post it here.