contentStream not available in pipe on RI after ftp

I am having problems working with the contentStream within the pipe after using ftp to put an edi (x124010) file to the reverse invoke server. I changed my mime.types (on the reverse invoke server) to assocaite the file extension along with the content type (application/EDIstream).

application/EDIstream x12 edi

I am migrating from 6.01 to 6.5. The same code worked fine in 6.01.

When I do a trace pipe I see the following:
0 contentStream {} = ‘’
It appears something is getting in there. BTW this is the same logged information if trace is execute on 6.01 (working version)

My flow serivce(residing on the reverse invoke)
performs a stream to byte then a byte to string.

For some reason the contentStream oject node, when mapped to the stream to byte value throw an exception.

Any help would be greatly appreciated.

Figured it out. Realized I could not see the contents when debugging. once I got pass an ACL issue it worked for me.

Unless someone can correct me, when you are using the reverse invoke server in this manner you will be unable to capture your file with the save pipeline service. As a result you will not be able to interactively debug your service.

This may not be an RI issue. For an object to be saved with the save pipeline service, it must be serializable. If the object is not, then it will not be saved.

You might try savePipeline, which stores the pipeline in memory. This service can save (in memory) all objects, even those that are not serializable.