Connection closed by remote host ftp

I have several services that accept data from an incoming FTP session and when the services complete return “226 ASCII transfer complete”. I have created a new one that receives data via ftp, which in turn sends the data HTTP to another server. In this case when all is complete and succesful, the ftp client receives “connection closed by remote host”. Does anyone know why this might be happening instead of the 226 return? Could it be because even though the pub.client:http service has completed, the http session is still active? How can I ensure the service sends a “226” message back to the client?

John, is this related to your HTTP timeout question at http://www.wmusers.com/wmusers/messages/117/1785.shtml?

Actually Dan, I’m a different John. I don’t believe it is related, interesting though as I have a sporadic “read time out” on a AS2 HTTP session waiting for an MDN, So I’ll be watching that discussion as well…

We are also facing the same problem. We tried changing ftp data and connection timeouts to 900 seconds but no use. We opened a ticket with webMethods and have been testing with several patches sent by webMethods but the problem is not solved.

Any ideas !!!

I’d like to revisit this issue. We’re now experiencing this problem. We are FTP’ing a file to a service and will receive “Connection closed by remote host.” but all the data gets processed by webMethods anyways. Srini mentioned a connection timeout; where is that located? Does FTP have a standard timeout?

Thanks
Cort

OK, since there were no responses, I had to revisit it myself. :slight_smile:

We determined the session on the mainframe FTP was timing out. We realized this after different files of different sizes would always time out after 4 minutes. Once we updated the inactivity timer to 30 minutes, we no longer received this message.

FYI.