Commond directory interface not available in new Administration

I have setup webMethods 10.7 in my local with standard, UM/IS/MWS installation using Oracle XE as db.

I am able to see new interface but the common directory section on it is still disabled.

Please provide any pointer how to enable it.

Hi Farid,

were the database schemas created using Database configurator prior to starting the MWS for the first time?
When starting the MWS for the first tiem with correct database schema defined it will initialize the User Database for the common directory.

Can you provide some screenshots where your common directory administration is disabled?

Regards,
Holger

Yes db schema was created using Database configuration and Commond directory is working from MWS. It also shows configured in user management page. But not in new UI. Please find below screenshot.



Hi Farid,

do you have a UM configured for Common Directory usage?
There was a change from 9.x to 10.x where using the MWS db schema for common directory exchange between MWS and IS is no longer possible (already deprecated in 9.12 but still working) in 10.x.

In IS under Settings → Resources is the SAML-URL configured correctly?
In IS under Settings → Messaging is the UM-Connection configured and working?
In MWS under Administration → My WebMethods → Cluster Settings check for the Common Directory settings.

See MWS Administrators Guide as well as IS Administrators Guide for further informations.

Regards,
Holger

Hi Holger,

commond directory exchange between MWS and IS was always available. The change between 9.12 to 10.x was that all updates to common directory is being started cascaded using UM queues from 10.x onwards. In my installation, UM url was not configured and I have done that now as well but no luck.

Any other pointers?

Hi Farid,

unfortunately I am not yet using 10.x components as we are still trying to complete our migration to 9.12.
For this we are still using the database JMS provider (meanwhile deprecated) for syncing the common directory updates back to the IS.

Regards,
Holger

Tried installing latest fixes. Even tried installing again with no luck.

May be its an issue with Linux image. I will try on Windows and get back.

Hello Farid,

When 10.7 was installed was Central User Management selected under Integration Server or Microservices Runtime Packages? Common Directory Services will appear disabled in the Adminstrator if the WmCDS package is not installed.

Regards,

Jason

1 Like

Thanks Jason,

Turns out that was the issue, Somehow, Integration server Central User Management selection was missed.

Reinstalling that fixed the issue.

1 Like

Dear experts,
I’m also trying to bring Common Directory Services into an Integration Server installation. As per Jason’s advise above, I installed “Integration Server or Microservices Runtime Packages” → “Central User Management”. However, the package WmCDS does not show up in my installation. I couldn’t spot anything missing in the installer looking like it would bring CDS into the system. What did I miss during installation?
Best regards,
Christian
P. S.: The item “Integration Server or Microservices Runtime Libraries” → “Common Directory Service Support” was already installed.

Is it appear at /IntegrationServer/packages folder. If yes, try to update your instance

Hi Christian, Assuming you are facing this issue on the same ISv10.7 env? please confirm

HTH,
RMG

Dear Farid and RMG,
thank you for the quick responses!
It’s a complete fresh installation of version 10.7. I also ran the SAG Update Manger. However, the package WmCDS does not appear in the Integration Server UI. It actually exists in /opt/softwareag/IntegrationServer/packages/, but not in /opt/softwareag/IntegrationServer/instances/<instance>/packages/.
Could it be a license issue? I’m using a license tailored for API Management (APIGatewayAdvanced104).
Best regards,
Christian

Try updating your instance using the instance script, to deploy the package as Farid notes.

If that doesn’t work, use an IS license; I’m positive that there are certain restrictions that the API Management licences (both standard and advanced) introduce.

KM

2 Likes

Dear Kasi,
thank you very much! The term “instance script” lead me to what I had missed. Now I ran

/opt/softwareag/IntegrationServer/instances/is_instance.sh update -Dinstance.name=<instance> -Dpackage.list=all

and WmCDS is finally available in my Integration Server instance.
Best regards,
Christian

1 Like

Glad that it’s resolved, Christian; you’re most welcome!

KM

Hi,

looks like a step in the installation procedure was missed.

During a fresh installation when “creating default instance” is selected all components/packages being installed are also propagated to default instance.
When I remember right this applies to the fact when installing new components/features which provide additionally packages to the IS that there is such a selection available too, where it can be choosen if they should be automatically added to the existing default instance or not.

Regards,
Holger