CentralUser Management: Logon Denied

Hi,

We recently had a password change activity for all webmethods databases (IS’es, MWS, Brokers) and application databases (External Datasources).
As part of this, we have updated the latest passwords in all of the IS, MWS screens.

But facing problem in CentralUserManagement.
When I do Test on the Database Pool Alias in IS, the test is success.
But when I associate it with CentralUsers Function Name, I see login denied in IS logs:

2012-06-29 14:29:19 BST [CommonLib.MWS.0002I] No registered exception delegate
Error creating database connection to: jdbc:wm:oracle://dbhostname:1521;SERVICENAME=WMXXX;SID=;MaxPooledStatements=100com.wm.dd.jdbc.oraclebase.ddd0: [sag-cjdbc42-0011][Oracle JDBC Driver][Oracle]ORA-01017: invalid username/password; logon denied

        at com.wm.dd.jdbc.oraclebase.ddb8.b(Unknown Source)
        at com.wm.dd.jdbc.oraclebase.ddb8.a(Unknown Source)
        at com.wm.dd.jdbc.oracle.OracleImplConnection.a(Unknown Source)
        at com.wm.dd.jdbc.oracle.OracleImplConnection.x(Unknown Source)
        at com.wm.dd.jdbc.oraclebase.BaseConnection.a(Unknown Source)
        at com.wm.dd.jdbc.oraclebase.BaseConnection.k(Unknown Source)
        at com.wm.dd.jdbc.oraclebase.ddaj.run(Unknown Source)

It appears that IS is trying to use an old incorrect password from somewhere.
The PoolAliasDefinition for CentralUsers in IS, Default and ExternalDataSource in MWS all have the correct password.
Can you guys here suggest where else could the IS be trying to use this incorrect password from. I have tried doing grep on the MWS/IS installations for this database information, but with no luck.
:confused:

Hi,
If this is not production environment, please try to do the following:

  1. Under JDBC pools, remove association to the current defined alias from centralusers pool.
  2. Save and restart the IS.
  3. Once Up, re-associate the alias with the centralusers pool.

HTH,
-Kishore

Hi Kishore… Thanks for replying.
Already tried that (many times). Does not work.
The logon denied error message returns as soon as I associate the central users functional alias with pool Alias and restart it.
Also when it happens, the IS freezes completely. I have to shut it down, and unassociate the Central users from configuration file and start the IS for it to work normally.