Central User Manager initialization failed with error : [POP.004.0201] (solved)

hi all,
I’m trying to upgrade webMethods 7.1.3 to 9.5 (Windows server 2003, sql server 2003)
In 7.1.3 we used only integration server and trading networks.
After carefully following all the steps for the upgrade process I started the following services

Software AG Integration Server

The server.log file contains following message

2014-03-17 13:51:07.030 [ISS.0024.0010C] Central User Manager initialization failed with error : [POP.004.0201] Cannot initialize MWS, invalid database schema is specified.

I presume its is an error in the database configuration.
Can anybody give a hint about how to solve this problem?
thanks

Is there any specific order that the 4 services should be started?
ie
command central, integration server, my webmethods server and platform manager.
and do I need all of them?

As Trading Networks now uses MWS for Administration (TN Console has been deprecated in wM 8 and removed in wM 9) you will need an MWS Installation as well.

This MWS Installation uses its own build-in User-Management system called “Central User Management” in a database component called MWS.

The IS tries to connect to this database schema for checking privileges i.e. for Monitor and Tasks.
I am not quite sure about TradingNetworks for this case.

My webMethods Server can not run without its database schema.
After the MWS has been started for the first time and has created the default users, groups and roles entry the message in the IS-server.log should stop to occur if there is a pool pointing to the MWS-schema and it has been assigned to “Central Users” function.

as far as I know there is no specific order for the services to be started in, but some functionalities will not work if the one or other did not finish their starting sequence up to that point.

Hope that helped.

Hi Holger,
thanks for your swift response.
I connected the CentralUsersPool to the database where all other webMethods stuf is located.
I tested the pool and is states that the connection is succesfull ‘Test of CentralUsersPool successful’
mws has run the first time, actually I dropped and recreated the mws database, ran it again and the error persists.
Do you have any suggestions.?

Just to let you know.
I solved the problem using the following procedure:
May be it is of any help to anyone
0) stop is and nws

  1. drop all database components for mws
  2. drop all database components for is
  3. create database components for is
  4. create database components for mws
  5. start mws
  6. wait for mws initialisation to complete
    This lasts 20 minutes, so dont be impatient.
  7. logon to mws
  8. set url to is to correct port (we use 5556)
  9. start is
  10. message is gone now

So probably it was a database configuration failure.

I’ve lots of other errors.
Don’t know if they are related. But when needed I’ll log them in diferent topics.