Cannot initialize MWS invalid dabatase schema is specified

Greetings,

I’ve just created a fresh instalation of webmethods in a vm.

I completed the installation and I can start IS, but I am not able to start MWS.

I also tested the JDBC pools and they are sucessfull as result.

I keep getting this error in full.log whenever I try to start mws.

I used DB configurator and tried to drop and create the tables again , but I am still getting this error:

" 2017-09-28 14:28:38 WEST (Framework:FATAL) - [POP.004.0201] Cannot initialize MWS, invalid database schema is specified
java.sql.SQLSyntaxErrorException: [SoftwareAG][Oracle JDBC Driver][Oracle]ORA-00942: table or view does not exist."

I can connect to the database with no problems and I have seen the difference in the amount of tables, after drop and create.

I am not sure what am I doing wrong.

Best Regards,
Ana Sequeira

Hi Ana,

after recreating the database schema/tables you will have to use the following command:
mws.sh -s default create
and start MWS once.

This initializes different configurations as well as the user store with the default users.

Please check your MWS/server/default/config/mws.db.xml for correct values.

Regards,
Holger

Greetings Holger,

I couldn’t use that comand mws.sh -s default create but the " mws.sh -s default init " did work for me.
But the problem remains,

I haven’t mention before, I am installing webMethods version 9.5.

Regards,

Ana Sequeira

Hi Ana,

can you please explain how you are creating the database tables for MWS?

I usually use separate schemas for each entry listed under Products.

After creating a clean schema for MWS with DB Configurator and installation of MWS whilst creating a fresh default instance this works for me.

Regards,
Holger

Hello Holger,

I am using one single schema.

And that schema has the 2 tablespaces that the documentation says to create. Also the user.

The information seems to be correct on the file “mws.db.xml”.

I’ve noticed that the query " SELECT COUNT(*) FROM TBLTHING WHERE IDTHING = 1;"
does not work for me. And it seems the tables “TBL…” are indeed missing.

I tried to install everything again using dbConfigurator. Still have error even with that query being successful

I have this on the log:
2017-09-29 16:27:19 WEST (org.eclipse.gemini.blueprint.service.importer.support.AbstractOsgiServiceImportFactoryBean:WARN) - OSGi importer [consumers] definition contains no interfaces: all invocations will be executed on the proxy and not on the backing service
2017-09-29 16:27:34 WEST (com.softwareag.security.idp.saml.SamlManagedService:ERROR) - osgi.configuration.area was not set/found.
2017-09-29 16:27:37 WEST (Framework:WARN) - Error initializing component [portlet] for provider [CoreServices]
java.sql.SQLException: [SoftwareAG][Oracle JDBC Driver]Operation cancelled by user request.
at com.wm.dd.jdbc.oraclebase.ddcr.b(Unknown Source)

Regards,