Cannot find language library

Hi, Forum

I just installed Tamino Server and found this strange messages from Tamino Manager.

Any idea?

Scott
screenshot.jpg

Hello Scott,

that is indeed strange!

Which platform and locale did you install on?

Thanks,
Trevor.

Hi Trever

I am on Win2k w/ Service Pack 3.
My locale is US and Enlish is the default language setting for the system.

I installed as ‘Administrator’ of the machine.

Regards,

Scott

Hello Scott,

this is quite mysterious - I haven’t seen this before.

When you say that you installed as “Administrator”, does this mean that you installed as a user called “Administrator” or as another user with Administrator privileges?

Which user is logged in to Windows, and which logged in to the System Management Hub when the strange messages appear?
(I am wondering if there is some permission problem preventing access to the language library - but this is really a suspicion.)

Which exact (four digit) version of Tamino are you running? The latest patch level is 4.1.1.7 (as of Friday 3/14/2003).
Lastly, where did you get the Tamino distribution from?

Thanks,
Trevor.

This problem appears in version 3 as well but there seems to be missing some library and no one can answer the question.

the library missing is probably inomsg.dll
Not only must this library be installed in the Bin folder of Tamino, it must also be correctly registered with System management hub. Please
a) check whether inomsg.dll is present in the Bin folder of Tamino
b) if yes, please provide a registry export of
HKY_LOCAL_MACHINE\SOFTWARE\Software AG\System Management Hub\Products\Tamino

Regards

Harald

I had the same probleam after installing 4.1.4.1
I found the inomsg.dll is in it’s location
The I found the following entry in event viewer:
Event Type: Error
Event Source: MsiInstaller
Event Category: None
Event ID: 11904
Date: 12/5/2003
Time: 1:08:43 PM
User: N/A
Computer: TAMINO1
Description:
Product: Software AG Tamino 4.1.4 – Error 1904.Module C:\Program Files\Software AG\Tamino\Tamino 4.1.4.1\Bin\inostren.dll failed to register. HRESULT . Contact your support personnel.

I ran the command:
regsvr32 "C:\Program Files\Software AG\Tamino\Tamino 4.1.4.1\Bin\inostren.dll"

And this solved the probleam.

Hello there,

I did encounter (today) the same issue : having the error message “Cannot find language library” when launching SAG services.
I digged into the installation logs and saw that the language libs were not correctly registered in the REGFILE.

But … that occured on a Solaris 8 64bits server (Tamino 4.1.4.1) …

On one hand runnning the regsrv32 on windows is easy on the other hand it’s not that straightforward on a nix platform.

Any help ?

Bertrand Martel
Software AG France

Hello Bertrand,

one of our colleagues (Theo Beack) ran into this problem on Solaris a couple of weeks ago.
In his case the system ran out of disk space during a restore operation, which prevented the REGFILE from being updated (and thus left it in an inconsistent state).

Our first idea was to try and repair the inconsistencies by hand - examining the contents of the Windows registry and inserting the missing values into the registry on Unix via the “regutil” command.
(The starting point was to execute:

   regutil enumrecurse "HKLMS\Software AG\System Management Hub\Products\Tamino\Versions\4.1.2.161\Message_Files"

… on Solaris, to see if the contents were the same as on Windows.)

Theo also found two [probably] simpler solutions for his situation:


I hope this is helpful for you!

Greetings,
Trevor.