Can not open Work File in NaturalONE Community Edition (Docker)

Hello everybody,

I am using NaturalONE Community Edition Version 9.2.1 on Windows 10 and the container versions of ADABAS (7.1.1) and of the NATURAL runtime (9.2.1).

I was trying to open a work file in an Natural program in the same fashion as posted here:
Work Files with NaturalOne over docker. Insofar I am aware that the container is based on Linux and not Windows.

So, my program looks like this:

The file TEXT1.TXT I created via the context menu of the library TRAINING → New → File. The content of the file is ‘ABCD’. I saved the file and Build the project. Now the project looks like this:

When I started the Natural Docker Container I mounted /opt/softwareag/Natural/fuser to the directory E:\NatONE\natural-ce-m\ on my Windows PC, and I can see the file TEXT1.TXT in the Windows Explorer:


But when running the program I am getting this error:

I also tried the following: I copied the file TEXT1.TXT manually into E:\NatONE\natural-ce-m, so it is on the main level which should be represented by /opt/softwareag/Natural/fuser/ within the container. Then I changed the path to the workfile as follows:

But I am still getting the same error.

Leaves me clueless, at the moment. So, any advice on this matter will be very much appreciated.

Best Regards,

Silly question but your define work file refers to #11 and the read work refers to #1

Perhaps they should both be the same?


1 Like

Hi James,

yes, you are right, that was the problem. I should have seen this myself, but sometimes one does not see the wood for the trees. Also a copy and paste thing here as combined two programs.

Thanks a lot anyway, for taking your time and having a look at it. That made my day.

Just want to add, that both methods work: Creating a file as a project resource thru the context menu in the SAG Designer as well as just copying it via the file system into a place which Natural in a Docker container can access. Might be interesting for others.

Best Regards,

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.