Caching

Hi All,

How to stop mediator7.3 from caching the sequence files and the payloads.

Can any one please help me in this regard, because of this caching i need to restart the mediator host every time i change my sequence file.

Thanx & Regards,
Nagesh.

Hi Nagesh;

Looks like I beat Mike Bernat to this, but i’ll use his wisdom. All credit his.
There is a property that you can use in your sequence that can turn caching of resources on and off: xbd.resource.cache (true/false)

Mike’s guidelines to using this property:

1. The property can be set anytime during the execution of a sequence,
and can also be unset or deleted any time, if you want to control only
some resources.

2. The property effects all cache activity, if “false” documents are not
gotten from the cache and they are not left in the cache.

3. In order to prevent the initial sequence from being cached, you must
set the property either via SMH or as a query parameter on the request.

4. Any resource with a “cid:” format of its url is never cached.

5. Setting xbd.resource.cache=false does not delete or remove anything
from the cache. So if you run a sequence without the property set, its
resources are cached. Run it a second time with the property set, and
"fresh" copies of the documents will be used. Run it again without the
property set and the copies cached in the first run will be used.

In addition you can use System Management Hub to refresh a particular resource or all resources.

Kind regards,
Rolf