C8Y Connectivity Plugin Exception

Hi

I have created a new project using the c8y connectivity plugin and using Apama 10.11.3

However when I run my project I get the below exception.
Please note that I tried on 10.7.2 as well but getting the same issue.

I am wondering if it could be due to the license file which is pointing to OS Linux instead of win (issue on latest license downloaded last friday) ?

Attached is the properties file with hidden creds.
Any help would be welcome please.
Thank you

2022-05-20 17:39:31.332 INFO  [21252] - Connectivity plug-ins: Loaded C++ plugin from path connectivity-batch-accumulator-codec.dll
2022-05-20 17:39:31.357 ERROR [21252] - <connectivity.chain.CumulocityIoT> Exception while creating plugin ApamaConnectivityForCumulocityIoT: java.lang.NullPointerException: 
2022-05-20 17:39:31.358 ERROR [21252] - <connectivity.chain.CumulocityIoT> java.lang.NullPointerException
	at com.apama.cumulocity.Transport.validateParams(Transport.java:1074)
	at com.apama.cumulocity.Transport.<init>(Transport.java:130)
	at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at java.base/jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.base/java.lang.reflect.Constructor.newInstance(Constructor.java:490)
	at com.softwareag.connectivity.impl.apama.ConnectivityLoader.newTransport(ConnectivityLoader.java:242)

2022-05-20 17:39:31.358 ERROR [21252] - Failed to initialize correlator: Connectivity plug-ins startup failure

The problem was that C8Y_BASEURL was set as an environment variable which the connectivity plugin uses to switch to microservice mode where it expects user name and password to be provided via environment variables as well. By removing the environment variable, the configuration is taken from the properties file as expected.

1 Like