Problem with websocket client connect with Cumulocity for Notification 2.0

Hi Team,
I am working for Notification 2.0 in micro-service basing on sample project in github.
‘ROLE_NOTIFICATION_2_ADMIN’ is enabled for micro-service.
But the websocket client can’t connect with Cumulocity, below is the error log.

2022-09-30 02:55:41.068 INFO 13 — [main] m.websocket.MoNotificationExample : webSocketUri:wss://<my.tenant.domain>/notification2/consumer/?token=eyJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJ0ZXN0dGVuYW50c3Vic2NyaWJlciIsInRvcGljIjoidDE0MjExMzgwNzMvcmVsbm90aWYvdGVzdDEzMDEwM3N1YnNjcmlwdGlvbiIsImp0aSI6IjE2NzU4OGQ3LWIzNzUtNDZkYS1iODIyLTczZGVjNTk4N2Y5NiIsImlhdCI6MTY2NDUwNjU0MSwiZXhwIjoxNjY0NTkyOTQxfQ.UCmJPv1yBCxjbqiGmIWquT-wjWbOhLKglOB-5Eel9jmUjwdnIWh8sXOcYj3Tj4WJQBtR98DQ0ThYw0SDX-XipRmVmm5mCvmqrDC9NPtgLVWqUZG1yNk0fAsvjAlqW32bh6trwBreo79uSI85C_wLXTlvzDXRvG-0rjZdhuuOLeQoSYMy4CPcLEVt9QbNFJBm0AXL6VJFUEE4TNw6HiknRkf8PtWAdRZZhV8QNDUmisBrDS6Q03bd7GLqAiptg1gAL5J-aEJcrmYkT5c798uyec3uu3zRORwi2CT-UitsgQKGDy6WMeHilSHvOT0LeHrIbXN9AWl87ShAfxjDn2ZD8g
2022-09-30 02:55:41.068 INFO 13 — [main] m.websocket.MoNotificationExample : WebSocket library: TooTallNate
2022-09-30 02:56:11.792 INFO 13 — [WebSocketConnectReadThread-30] m.w.t.TooTallNateWebSocketClient : WebSocket closed Code:1002, reason: Invalid status code received: 500 Status line: HTTP/1.1 500 Server Error
2022-09-30 02:56:11.792 INFO 13 — [WebSocketConnectReadThread-30] m.websocket.MoNotificationExample : Connection was closed.

Any suggestion for this ? Thanks for reply.

The version of my tenant is ’ 1013.0.260

Hi,

Don’t know what causes the internal server error. Did you create a subscription beforehand? Did you request the token for that subscription? Have you tried e.g. Postman connect to the wss?

Kind Regards,

Marco

Is this on cumulocity prod? If so it is a known problem that is already being worked on.

Yes, it’s on cumulocity SaaS in APJ.

What is the name of the tenant?

the domain for this tenant is apj-demos.cumulocity.com

If it’s cumulocity.com then this problem should already be fixed.

I tried my tests again and it is fixed!

Hi Robert,
Any configuration is necessary ? E.g: enable some messaging service ?
That is great if you can share your test code with me. My email address is weihan.chen@softwareag.com

It’s fine now.
The issue is caused by running with wrong version of c8y jdk.
My tenant is 10.13.260, while run with 10.14 for bugs