Browser Inbox hosted on separatemachine tomcat fails

KS, what you did is correct…copying the workflow.war file to the Tomcat web apps directory.
What JVM are you using for Workflow ? Are you using the jvm that is installed when webMethods is installed ? For example <webmethods>\jvm\win.sun13
Have a look at the file srvmgr.bat in <webmethods>\WorkflowServer\bin
What is the setting for JAVAPATH ? If you are using the 1.3 jvm you should be ok…but beware if you are using 1.4+
I don’t think Workflow 6 is supported on jdk 1.4.+
According to the 6.0.1. install documentation, the supported jdk for Workflow is 1.3.1.

Regards,

Wayne

Wayne,
Thanks for your reply. I tried installing jdk 1.3.1_09 in place of 1.4.1 and tried. It doesn’t make any difference? I still get the error. On the same note, somebody who took a quick look at the errors told that it is something to do with the classpath/path… I could not ask more. Please let me know what else could be the problem.
Thanks,
Sangeetha

Especially the line
“java.lang.NoClassDefFoundError: COM/activesw/api/client/BrokerCallback” seems to tell that it needs some other jar or something that it cannot find… Any ideas?

Sangeetha, you are right…the NoClassDefFoundError is the problem. Now the question is: Why isn’t this class being found on your server ? If the JDK and Tomcat were installed as per the instructions and the Workflow.war file was copied to the Tomcat webapps directory, then getting Tomcat to access Workflow is usually easy (and painless).

Here’s a few questions/suggestions:

  1. The BrokerCallback class is in the client60.jar. This jar file should be in <tomcat>\webapps\Workflow\WEB-INF\lib directory. Tomcat should deploy the jar files from Workflow.war into this directory when it starts up. Is the jar file there ?

  2. Is there a classpath specified as a system environment variable ? If so then what is it set to ? Note: our server does NOT set a classpath system environment variable.

  3. Did you follow the full install instructions for the JDK & Tomcat ? Did you set your JAVA_HOME environment variable ? Did you add
    %JAVA_HOME%\bin to your system path environment variable ?

  4. Make sure there is a temp directory under <tomcat>. If it’s not there create it.

  5. Make sure you run the Workflow configurator and setup the database info. Verify that you can access the userid/password you specified by using a tool like Free Toad.

  6. On the Workflow login page (at http://catodv28:8080/Workflow/wfservlet) are you specifying the “Server:” info as follows ?
    <workflow_server_hostname>:5001

  7. Are you running Workflow server as a service or from the command (batch) file ? The command file (srvmgr.bat) is in <webmethods>\WorkflowServer\bin directory

  8. If all of the above look ok, then do the following:
    a) shutdown Tomcat
    b) delete the <tomcat>\webapps\Workflow directory,
    c) Delete the <tomcat>\work\Standalone\localhost\Workflow
    d) Copy the Workflow.war file from <webmethods>\WorkflowServer to <tomcat>\webapps (make sure you replace the war file that is there)
    e) start Tomcat
    f) Try logging in again (make sure you specify “Server:” on the login page)

Let me know how it goes.

FYI: we are using Tomcat 4.0.4. here

Regards,

Wayne

Wooho great Wayne, It worked!!
Thanks for all the pointers, I followed them all one by one. I guess the war file that I copied was from a wrong directory or something… Or may be just that the tomcat needed restart/deletion of older directories etc. Whatever it is, it is workign now,

Thanks again,
KS