Authentication of Tamino UDDI

Hi,

I have installed the new preview version. Everything work fine except the authentication. I followed the README.TXT to turn on the authentication:

1. Set uddi.useAuthentication=true
2. Add role & username in tomcat-users.xml

However, when I started the Tamino UDDI Browser and goto the “HOME/LOGIN” or “PUBLISH” page, the defined user could not log-in.
I got the following error:

"Your login failed. Please check your username and password."

Please help.

Thanks…Tony

Hi Tony,
your error message tells me that authentication is enabled in your registry. That is the good news. The bad news is that I do not really have a clue why the authentication fails.
First, make sure the Tomcat memory realm is really enabled in your Tomcat installation, see
Realm Configuration HOW-TO. If this does not help, just send me zsolt.beothy-elo@softwareag.com your tomcat-users.xml file and the web.xml file of your Tamino UDDI Registry. It is located in %CATALINA_HOME%\webapps\TaminoUddiRegistry\WEB-INF. I will try to fix the problem.

Regards,
Zsolt

Hi,

I have the same problem with the Authentication.

Also, when I publish a new Business, the “Service” tab is inaccessible. How can I register a new service?

Thanks,
Puny

Hi,

You can go to the web.xml file of your Tamino UDDI Registry, which is located in
%CATALINA_HOME%\webapps\TaminoUddiRegistry\WEB-INF. Change line 67 from something like http://localhost:8080/TaminoUddiRegistry//authenticate to http://localhost:8080/TaminoUddiRegistry.

Cheers.