ATT1190930ATT to a meaningful filename in pubmimeaddBodyPart

I need to ensure that the InputStream which I add to a multipart MIME object is named appropriately, including the file extension; for example, `por_ddmmyy.csv.’ I use the description parameter of pub.mime.addBodyPart to name the file in the MIME header but this does not rename the attachment itself.

 The effect is that, after my multiplart MIME is delivered, an email attachment is visible with a filename of `por_ddmmyy.csv.' However, when the user tries to save the attachment, its filename defaults to something like `ATT1190930.ATT'. 

  Has anyone solved this problem before? Am I missing something in the process of attaching an attachment to a MIME object here? 


I ended up working through the code in wmSamples, where a gif is successfully attached.

It turns out that it’s done using the contenttype parameter. Whereas I previously entered ‘text/csv’ I now enter ‘text/csv;name=“por_ddmmyy.csv”’