ARIS Centrasite Integration Issue

Hi When I give Centrasite URL http://hostname:53307 in ARIS 9.6 Architect and click on Test Connection, I get below error:

WSS1601:Security requirements not met. Transport binding configured in policy but incoming message not SSL enabled.

Kindly help.

Please see readme section 4.1.1 of the latest 9.6 fixpack
https://empower.softwareag.com/sl24sec/fixsis_extern/FIXSIS2/ALL-PC/INM/96/INM_9.6_Fix8_ALL-PC_Readme.txt

Daniel

1 Like

Thanks a lot for immediate response. My Centrasite Version is 9.0. ARIS version is 9.6

I have implemented below suggestions from FIX rlease notes but I still get same error.I restarted Centrasite runtime by executing /profiles/CTP/bin/sagctp.sh stop and start. Is there any other command I need to execute to restart Centrasite tomcat.

Create a backup copy of ImportWS.aar before doing any changes.
Remember file permissions and ownership.
2. Extract ImportWS.aar into a temporary directory.
Depending on your zip/unzip utility, it might be required to change the
file extension from .aar to .zip.
3. Open META-INF/services.xml in a text editor
4. Find the below parameter
true
5. Add the following line below it
false
6. Repeat steps 4 and 5 until the “addPoliciesToWsdl” parameter is added for
all the services. Please note that there are 9 services in service.xml
7. Repack (zip) ImportWS.aar with the extracted content. Make sure the
modified services.xml is included.
8. Copy the modified ImportWS.aar file to
<SAG_Home>/profiles/CTP/workspace/wsstack/repository/services/
If needed, adapt file permissions and ownership.
9. Restart CentraSite Tomcat (CTP)

Hi Nagaraju,
colleagues prepares the attached description for a work-around, hopefully it will help you as well.
Regards,
Gerald
Solving the communication issue between ARIS and CentraSite.docx (124 KB)

1 Like

Hi Gerald
Thanks a lot for work around document. I followed all instructions but get an error. Kindly find the attached screen shot.

Request to kindly provide a pointer.
Error.docx (60.1 KB)

Hi Nagaraju,
from the error it looks like the CentraSite certificate was not correctly loaded into ARIS or the hostname from the certificate does not match the one defined in ARIS. Are both fully qualified host names? Can you double check?
Otherwise, would you be available for an online support session? For this we will need your email address.
Regards,
Gerald

1 Like

Hi Gerald
Thanks a lot. I did key store generation etc in E:\SoftwareAG\ARIS9.0\jdk instead of E:\SoftwareAG\ARIS9.0\server
I think that is causing issue. I will do in server folder and update you.

Hi Gerald
Thanks. Now SSL error is gone. But I get error that “Centrasite version is too old. Minimum 9.5 is needed.”
My Centrasite is 9.0
Is there any work around for this. We have upgrade plan next year but mean while I want to start SOA in my organization.

Hi Gerald
Sorry I guess you are very busy. Is there any work around available for the error “Centrasite version should be 9.5 and above” I get this error after establishing SSL handshake between ARIS and Centrasite.

Hi Nagaraju,

sorry for the delayed response. Unfortunately, it is not so simple since we have put in a check in the newer ARIS 9 in order to guaranty that the SSL connection can be established. I see two solutions:

  1. Upgrade CentraSite, this is the preferred solution
  2. we could provide a patched JAR file for the ARIS server so that the check is disabled

Regards,
Gerald

Hi Gerald
Thanks a lot for the response. We are upgrading Centrasite along with other webmethods suite next year. Currently I am in urgent need of completing POC but stuck due to this issue. It would be of great help if I can get a patched jar without version check. Kindly consider.

Hi Gerald, sorry I guess you are very busy. Request to kindly consider providing patched jar. Thanks a lot

Hi Nagaraju,

in order to asure that all matched, we would need the exact build number of the ARIS server, or better the version in the name of the JAR file. it can be found in the AEIS directory and the name is like
y-aris-server-bl-csinteg-[VERSIONS_NUMMER].jar ).

Regards,
Gerald

Thanks a lot Gerald.
Here is the jar version

y-aris-server-bl-csinteg-96.0.3.3.jar

Hi Nagaraju,

please find attached the modified ZIP file which avoids the version check for your use case. Before you copy the file to your client and server, please copy the old file to a safe location. Once you have extracted the JAR file from the archive, you need to replace the corresponding JAR file on your server and client, here ([USER_DIR]\ARIS90\DownloadClient[SERVER_IP]\lib) .

Kind regards,
Gerald

P.S.: the file was too big for the community, I placed it under ftp://ftp.softwareag.com/outgoing/M2E/y-aris-common-core-96.0.3.3.zip

Hi Gerald
Thanks a lot. Sorry for delay in response. This tested fine with thin client. Just to double confirm, y-aris-common-core-96.0.3.3.jar can be found on ARIS Design server in eight locations. do you recommend to replace in all locations.

Also for thick ARIS Client can you kindly let me know where to put this jar file. Thanks a lot

Hi Gerald, i have similar issue in ARIS Server, but i can´t load the file in ftp://ftp.softwareag.com/outgoing/M2E/y-aris-common-core-96.0.3.3.zip. would u upload this file to find it, please