ApplinX Server - deployment procedure

In J2EE deployment manager (from eclipse) upon creating .war of Applinx Server, what is the process of deploying this .war to the target location ?

ApplinX Version: 8.0.1

Thanks in advance

Hi Aki,

It really depends on the type of server you want to deploy the WAR file on (Tomcat, Websphere, Weblogic…).

In Tomcat for example it is sufficient to Drop the WAR file under the tomcat_installation_dir\webapps directory and restart the server.

Basically, you should go to the server administration tool and select the deploy option. Usually you’ll be asked to provide the WAR file and then you should follow the administration tool instructions.

Best regards,

Hi Ohad,

Thanks for the prompt response - we are using Tomcat and had tried to place it in “tomcat_installation_dir\webapps” directory and the server did get deployed.
Despite the ApplinX server getting deployed and the admin console able to access it - the JSP application deployed at same location was unable to interact with the ApplinX server.

Thanks again

Aki / Amit Maheshwari

Hi Aki/Amit,

Are the webApp and APX server on the same machine?
The Admin console connecting to APX server successfully suggests the deployment was successfull.

I’d suggest looking in the config/gx_appconfig.xml file of the web application, and see if the server URL and the application name are setup correctly.

Please let me know if this works out for you.

Hi Ohad,

The webApp and APX server are on the same machine and both .war files are deployed under the same directory “tomcat_installation_dir\webapps”.

This machine also has the ApplinX server installed, the following steps have been followed to try the deploy

  • Generate ApplinX Server .war file: On ApplinX Workbench right click on Application and select “J2EE Deployment Manager”, next select “ApplinX Server”, “J2EE Server Type”, Port and License information
  • Stop service “Software AG Common Tomcat cp8.0”
  • Stop service “Software AG webMethods ApplinX 8.1”
  • Place “ApplinXServer.war” at “tomcat_installation_dir\webapps”
  • Restart Tomcat server
    Result: Admin Console connected but Application unable to access ApplinX server
  • Stop Tomcat server
    Result: Admin Console disconnects
  • Remove “ApplinXServer.war” from “tomcat_installation_dir\webapps”
  • Start service “Software AG Common Tomcat cp8.0”
  • Start service “Software AG webMethods ApplinX 8.1”
    Result: Admin Console connected and Application able to access ApplinX server

In this context is there a different config required for the above two scenarios ?



we tried to reproduce a problem here and the deployment of the application seems to work just fine.

Could you give more details what was the error you received (a screenshot, please) and at which point?

Another matter: Ohad suggested you look into the config/gx_appconfig.xml file. Is everything defined there correctly?