API Gateway Issues accesing API

What product/components do you use and which version/fix level?

API Gateway 10.11

Are you using a free trial or a product with a customer license?

Product with customer license

What are trying to achieve? Please describe in detail.

I have a REST API defined in Integration Server in Green Zone and I am trying to expose the REST API via API Gateway in DMZ using reverse invoke.

I have configured port 16001 as external port and 16002 as the registration port in API Gateway. In the Integration Server, I have defined a Internal Port 16002.

Now when I using API portal to test the API using port 16001, the server keeps spinning and there are no information in the API Gateway logs. I am clueless about the place where the request is stuck.

Has any one implemented a simialr API Gateway set up? If so can you suggest if I a have missed some thing due to which the API is not accessed.

Do you get any error messages? Please provide a full error message screenshot and log file.

No Error Messages.

Have you installed latest fixes for the products

No fixes. It is a plain vanilla installation.

Hi Vallimeenal,
Few things you can try - please check if your API is accessible through clients like postman.
Also, if your API Portal is external please check for any firewall issues.

Regards.

Thanks Prabha. In my case API Portal and API Gateway are running on the same machine.I do not see any firewall problem as I am trying to access the API from with in the box. And the issue still persists.

Thanks
Vallimeenal.M

Hi All this issue is resolved by adding an internal server port in Gateway.
Thanks
Vallimeenal.M