API Gateway Auth using MWS LDAP config

Hello,

I have a problem with my new Api Gateway 10.7 configuration
I use MWS Roles in API GATEWAY Teams config so MWS use a lot of CPU and the Gateway time seem to be more than 3 min to respond witch is not normal

can you help me out maybe I need to add some extended setting config ?

or maybe using Teams with MWS Roles is not the best way ?.

Regards
Ouzzine.

My understanding is that using Central Directory (via MWS) is not supported by API GW. IS will let you set it up, but it is not intended to work (one of the many disappointments we encountered after assuming that API GW being hosted on IS was going to simplify/unity many things. Mostly doesn’t because API GW (over?) relies on Elasticsearch to store everything.)

For our config of API GW, we configure to connect directly to the directory service (Active Directory in our case).

1 Like

Hello reamon,
it works for me by using MWS Roles in teams definition in API GATEWAY it just it impact the performance with 7gb in JVM MWS consume a lot of CPU and it impact the response time ( 3min )
also I have the watt.net.maxClientKeepaliveConns =0 will it impact us ?

Interesting. On page 18 of the API Gateway User’s Guide for 10.11, and page 226 for 10.5, it states:

Note: Central User Management is not supported with API Gateway.

Perhaps this is documentation “bug”. Or is the root of the performance issue you’re facing.

For watt.net.maxClientKeepaliveConns, seems unlikely to be an issue based upon the description of this parameter in the IS Administrator’s guide.

1 Like

but when I shutdown MWS service its working fine and no performance issue
I think its related to Application Cache but I don’t know how to give priority to the use of cache instead of checking each time in MWS do you have any idea about this Thanks

My suggestion is, in the absence of updated information from SAG, you stop trying to use Central User Management with API Gateway. The current documentation says it is not supported.