ApacheModuleIno.so again

[root@rhlx01 bin]# ./httpd
Syntax error on line 1036 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/tamino/common/lib/ApacheModuleIno.so into server: libsagrgs.so: cannot open shared object file: No such file or directory

What’s wrong?

I’m on RedHat Linux 7.2 Server. SAGNet claims Tamino should work on it.
The libs are in their folders.
Do I need additional libs? Or it is just the RedHat?
The Apache I use was found on the Tamino CD (1.3.14)
Actually, the Tamino is for SuSE Linux 7.1/7.2. But there was no problem at installation.

the same problem on SuSE linux Pro 7.3

Hi Fran,

You might like to check whether the environment variable LD_LIBRARY_PATH is set correctly. Once you have logged into which ever account you are attempting to start Apache under check that the above env var includes the directory in which the missing library is located. An alternative may be to try using the Apache directive LoadFile but I have always found it necessary to have LD_LIBRARY_PATH set correctly whatever.

I suspect that the root of your problem is that you are attempting to start Apache from user root (which is fine). Unfortunately the correct environment (as configured by contents of sagenv, inoenv, argenv etc.) only tends to be set up for the sag account (ie. the .profile of this account is usually edited to call sagenv etc.). Hence a quick and dirty solution to your problem may be to source the .profile for the sag account before attempting to start Apache when logged on as root.

Hope this helps.

Kind regards,


thanks for pointing me out. It works now fine. Couldn’t check it any earlier, only today.

I’ve included the following in the /etc/profile
(under RedHat):

# setting up tamino env
if [ id -g = 0 ] ; then
. /usr/local/tamino/sagenv.new

this will set SAG env.vars for the root groups only. Evereyone can fine tune it for his own needs :slight_smile:

Thanks again.

Glad to help.

Kind regards,