Redhat 7.2 Apache modules fail to load

Version - - apache-1.3.23

Apache fails to start on my install.

The files are in the path specified.

I can’t find the source code to recompile module with apxs.

Can anybody help??

Stopping httpd: [ OK ]

Starting httpd: Syntax error on line 274 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/apache/ into server: /usr/lib/apache/ cannot open shared object file: No such file or directory

LoadFile /usr/lib/apache/
LoadFile /usr/lib/apache/
LoadFile /usr/lib/apache/
LoadFile /usr/lib/apache/
LoadFile /usr/lib/apache/
LoadModule ino_module /usr/lib/apache/

<Location /tamino>
SetHandler ino
Regfile “…/SAG/common/rgs/REGFILE”

Hi Rooty,

What version of Tamino are you using? The .so objects you list do not look familiar. Are they the libraries for Apache v2 support I wonder? Where did they and your Tamino kit come from?

The Apache installation you are trying to use, is it the one which came with your Tamino installation CD or was it part of the RedHat 7.2 distribution?

If it was the later, then I suggest you install the Apache that comes with Tamino.

Kind regards,


hi Simon

just downloaded the most recent trial… I was able to get past that error by adding /libexec to my /etc/ file and running



Now i have this problem.

[root@internet2 apache]# /usr/local/apache/bin/apachectl start
[Tue Oct 8 08:49:35 2002] [warn] Loaded DSO /usr/local/apache/libexec/ uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
[Tue Oct 8 08:49:35 2002] [notice] Handler ino(vx.y): SAG path set
[Tue Oct 8 08:49:35 2002] [notice] Handler ino(vx.y): registry init successful


hi there rooty,

There’s been a few threads on this subject - the links are below. The solution is to use the Apache that comes on the Tamino CD because this has been build without EAPI support.

kind regards, Stuart

Tamino apache module and Apache v1.3.22 and EAPI problems
Problems with
Tamino Module for Apache on Linux

Thanks Stuart, I found them too…

also found some older threads on my original post with no resolution… hope i helped with future fixes for that problem.

I had to recompile apache without mod_ssl…
:confused: bummer, but it worked :slight_smile: