Adpter Error Please Help

Hi Every one,

I am running flow service, i am using batch insert adapter in this flow service

when i run this service i am getting below error,when i run directly batch insert adapter working fine but in flow service it is not working…what would be the reason …how to solve please give suggestions

[ART.117.4002] Adapter Runtime (Adapter Service): Unable to invoke adapter service File_Operation.Adapters:Batch_Insert_OrderDetails.
[ADA.1.316] Cannot execute the SQL statement “INSERT INTO WM.ORDER_DETAILS(ORDER_ID, QUANTITY, PRICE, FIRSTNAME, LASTNAME) VALUES (?, ?, ?, ?, ?)”. "
(17041) Missing IN or OUT parameter at index:: 1"
Missing IN or OUT parameter at index:: 1


make sure your inputs are in Document List type, seems the error indicate it’s missing the second record (index 1).

Hi tongwang,

           Thanks for the reply, my problem solved :) and one request tongwang,i was trying to 

write data from database to flatfile but flatfile not generating on mentioned path i am not geeting

output.I posted this problem but still my problem not solved can u pls help me.