Add and validate xml files with namespaces to a collection

I’ve got a problem with adding xml files to a collection with schema validation.

I’ve converted the attached custacc.xsd into a .tsd file (with the Schema Editor).
As expected, I had to define:
-schema name
-collection name
Then I inserted the schema into a collection.

When I now want to add xml files (e.g. the attached custacc9.xml), the error occures:
“schema not found”

The schema for the xml file is correct, I checked it with an external parser.
I think the error is because of the 3 defines I had to make while uploading the schema.

What do I have to add there that it fits to my xml files?
I tryed same changes in the schema and in single xml files, but I didn’t manage it to upload any xml file with schema validation.

<Customer id="1010" xmlns:xsi="" xmlns="" xsi:schemaLocation=" custacc.xsd">



Thanks for help,
Best Regards
Gerrit Hoven
custacc.xsd (11.2 KB)

A xml document to validate.
custacc9.xml (3.98 KB)


which problem did you observe? After defining the schema I get the following message and similar ones when attempting to store the document:

<ino:message ino:returnvalue=“7763”>
<ino:messagetext ino:code=“INOXDE7763”>(cvc-datatype-valid) An invalid value has been found during validation</ino:messagetext>
ino:messagelineLine 57, Column 10: datatype validation for element ‘custacc:TaxRate’ of type xs:decimal failed:</ino:messageline>

Reason is, that an xs:decimal of XML Schema needs to use a “.” instead of “,” in the lexical representation. Once you have changed that in the XML document, I can store it without any problem.


Hello Ulrich,

I didn’t get any problems with defining the schema. Perhaps your problem is because of regional input settings? Or I have to change all my xml files if I get the same error, what would be unlucky.

Can you perhaps give an instructions what you did? First I want to add xml files with schema validation with X-Plorer for testing. But that doesn’t seem to work here.
Again the error desription: When adding the xml file after the schema is in the collection, it says “Schema not found”.

After this, I hope I will manage it out of a Java application.


Hi Gerrit,

attached you’ll find the schema file with additional Tamino markup.
There is no problem to define the schema.
However, as mentioned below, you have to modify your data in order to be valid with respect to xs:decimal - you may also check the XML Schema spec ( which does not support any regional settings in this context.

custacc.tsd (11.6 KB)