Accessing rest URL in Apigee Edge

I wanted to access my Integration rest services form different systems.
what are the configurations are required?

when I am accessing directly (http://localhost:5555/restv2/Training.resrResourcces:myMsg/myMsg)

Hi,
Connection refused can mean that there is no server at 5555, You can confirm that Integration Server is up and running by calling host:port from a browser or by checking the server logs at /IntegrationServer\instances\default\logs/server.log.

-NP


Thank you Nagendra Prasad,

I have created a restv2 service when I am accessing in my local system( where I installed IS) it’s working fine. When I tried to access same URL form different system , then I am facing this issue.
I wanted to use my rest recourse as target system in Apigee edge. Then I am getting error message

Hi @sazhad
In the earlier screenshot , the rest resource is being accessed using POSTMAN through localhost:5555 which was failing.
But from your previous post, the problem is that you have a rest resource on another machine which you want to use through Apigee Edge?
Have you confirmed the target Integration Server is reachable from the client?
Please provide more details about the scenario , it will help.

-NP

1 > I have a service flow of weather API
2 > I created rest resource for the same - http Method as GET
when I am accessing it on postman to rest resource it working fine and I am able to get the response.

3 > Now I tried to access rest URL as a target end-point in Apigee Egde.
4 > I deployed it on test environment successfully
5 > when I am accessing the proxy URL I am getting error as : 503

You will need to map the end-point after importing the API, the default value will almost certainly be wrong. Make sure that you can call the API directly from the machine where your IS is running e.g.

regards,
John.