Access denied to API Gateway

What product/components do you use and which version/fix level?

API Gateway 10.7

Are you using a free trial or a product with a customer license?

Product with customer license

What are trying to achieve? Please describe in detail

Need help fixing the error so i can be able to login to API Gateway

Do you get any error messages? Please provide a full error message screenshot and log file.

2022-02-22 09:09:34 ERROR [apigatewayui] [com.softwareag.apigateway.ui.utils.SAMLAssertionUtil] - 1041: Authentication Failed with status code 401
2022-02-22 09:09:34 INFO [apigatewayui] [com.softwareag.apigateway.ui.utils.SAMLAssertionUtil] - getLocation: null
2022-02-22 09:09:34 INFO [apigatewayui] [com.softwareag.apigateway.ui.utils.SAMLAssertionUtil] - getHeaders: {WWW-Authenticate=[Basic realm=“Integration Server”, encoding=“UTF-8”], Connection=[close], Content-Length=[0]}
2022-02-22 09:09:34 ERROR [apigatewayui] [com.softwareag.apigateway.ui.ISConfiguration$1] - Attempt to login with technical user failed: : Authentication Failed with status code 401
com.softwareag.security.jaas.principals.SagGeneralSecurityException: : Authentication Failed with status code 401
at com.softwareag.apigateway.ui.utils.SAMLAssertionUtil.getISSession(SAMLAssertionUtil.java:122) ~[com.softwareag.apigateway.webapp.apimanager_10.7.0.0013-0418.jar:?]
at com.softwareag.apigateway.ui.utils.SAMLAssertionUtil.getISSession(SAMLAssertionUtil.java:90) ~[com.softwareag.apigateway.webapp.apimanager_10.7.0.0013-0418.jar:?]
at com.softwareag.apigateway.ui.utils.SAMLAssertionTechnicalUser.getIsSession(SAMLAssertionTechnicalUser.java:29) ~[com.softwareag.apigateway.webapp.apimanager_10.7.0.0013-0418.jar:?]
at com.softwareag.apigateway.ui.ISConfiguration$1.run(ISConfiguration.java:108) [com.softwareag.apigateway.webapp.apimanager_10.7.0.0013-0418.jar:?]
at java.util.TimerThread.mainLoop(Timer.java:555) [?:1.8.0_312]

APIGateway.log (291.2 KB)
server.log (153.0 KB)

@siqelo.ntsimane , This is new installation of the API Gateway product ? if so was API Internal Data store and Integration server on difference machine ? it seems to be server local time sync issue. Kindly work with your server admin to sync it up.

Hi DINESH_J

yes its the new installation and both API internal Data Store and IS are on the same machine. Can you please maybe give me the guidelines on how to sync it up

Hi,

I got the same problem at API Gateway 10.5 with fix 22. I do not know how to solve it. Can you guys help me about it?

Usually this comes when you use wrong license. e.g., Integration Server license instead of API Gateway license.