XMLCoder decode invalid data type comwmlangxmlDocument

Hello,
Sorry, I didn’t quote the most important part.
So,
when my customer send me purchase order that begin with:


[B]Quote:[/b]

<?xml version = ‘1.0’ encoding = ‘ISO8859-2’?><!-/Quote-!>



SAP business Connector 4.6 SR1 (webmethods Integration
Server 4.6 embeded) produce erroe in server log:
[B2BCORE.0076.0007] XMLCoder decode invalid data type:
com.wm.lang.xml.Document
and doesn’t parse xml document send by http protocol.
But, when I test sending same document but with modified
first line:

[B]Quote:[/b]

<?xml version=“1.0” encoding=“ISO8859-2”?><!-/Quote-!>



everything works fine. Problem is that first line is
generated automaticaly and this worked till a few days ago.

Please help
Mladen

Hmm. This is a strange one. The only difference between the two is obviously the ’ vs. " According the the W3C recommendation, either quoting style is acceptable. Did something on the BC box change in the last few days (an upgrade of something)? You probably ought to check with SAP regarding this apparent bug.

Hi,

I was getting same error.I changed encoding from UTF-8 to ISO8859-2 and it worked.
You probably can change it from SO8859-2 to UTF-8.

However i am still uncertain of this. I will let you know if i find solution.

regards
Sumit