(XML to Database) Cannot inserting data from xml to table in database (oracle)

Im trying to insert data from xml file to table(oracle) directly
my step is :
pub.file:getFile for insert the xml file
pub.xml:xmlStringToXmlNode for map pipeline in bytes to service in $filedata
pub.xml:xmlNodeToDocument for map pipeline in node to service in node and service out document to document (table field)
insert adapter

its work but only insert 1 row of data…the xml contain 12 row data

Can anyone help me to find what step im missing?


You can only insert all XML data object unless the target field type in the Oracle is CLOB/BLOB and then you will update your adatper service jdbc field type accordingly and insert it.


thanks for your attention mrg.

I have change the field type to CLOB
and the field type on insert adapter too, but the same result i found here… just 1 row data inserted…

any other suggestion?

thank you :slight_smile:

solved… need looping :D…
thanks :smiley:

OK great!

Have you tried BatchInsert Adapter Service?