XML Document does not Validate

I have another problem and I think this could be something minor or just simply my own fault. In my sequence I validate the incoming XML document and then I evaluate whether the document is valid or not. The problem seems to be that my document does not validate at all. I have used XML Spy and the document is 100% correct (when validated against the schema I’m using). I also went a step further and wrote a script and invoked the xerces parser to validate the document and again it validates 100%.

Why doesn’t the document validate when I run it through my sequence? Please find attached the rather simply sequence:

< !–{Name: ValidateDocument};{Notes: }–>

< !–{Name: TestValidateCondition};{Notes: }–>

< !–{Name: Transform};{Notes: }–>

< !–{Name: ValidDocumentResponse};{Notes: }–>

< !–{Name: step};{Notes: }–>

< !–{Name: step};{Notes: }–>

< !–{Name: step};{Notes: }–>

Any ideas what the problem could be?


I found the cause of the strange behavior I encountered in Mediator. I added a SagLogger step right after the validation step and noticed the following message in the DefaultComponentFactory.xbd.log:

---- Properties -----
xbd.validator.schemaused = http://localhost:8080/Sequences/Benchmark/xsd/Patient.xsd
xbd.validator.isvalid = yes
xbd.validator.dtdused =

which meant that the XML document did validate correctly and then it hit me. I test with a "TRUE"instead of a “yes” in my if statement in the sequence, it read as follows:

and should have read:

After making the change the problem was solved. Silly user mistake after all.

Theo :rolleyes: