XDK110 Cumulocity Application: Application fails at MQTTRegistration: requesting credentials

Hello,

I am trying to run the application “cumulocity-xdk-agent” on my XDK110. Everything goes fine until it tries to get MQTT credentials.
I followed the .readme and can’t find the source of error.
Does this application still work or am I doing something wrong. I don’t get the errors, that are statet in the .readme.
I registered the device on my cumuolcity tenant as well with the needed MAC address of my device.

Best regards,
Harish Rasiah
Business Developer Manager
LEGIC Identsystems AG

Hi Harish,

the agent still works if you use it without TLS:

MQTTSECURE=FALSE
For some reason the TLS communication between the XDK and Cumulocity Endpoint fails.

Regards Christof

P.S. I developed this agent


Hi Christof,
Thank you for the quick anwser.
So i tried to set MQTTSECURE to false (it was on true before) and i get the error msg’s as seen in the picture i uploaded.
When MQTTSECURE is set to true, i get the initial problem, where the application cant continue at “requesting MQTT credentials…”

There is also a section with “APP_MQTT_SECURE_ENABLE” which is set to 1:

/**

  • APP_MQTT_SECURE_ENABLE is a macro to enable MQTT with security
    */
    #define APP_MQTT_SECURE_ENABLE 1

Do i have to change this section as well? Sadly I am not a coder, therefore sorry if I am asking a rather fundamental question.

Note: I tried to troubleshoot it as well (the steps with adding XDK nature, clean and rebuild etc.) but nothing worked for me.

Best regards,
Harish Rasiah

Hi Harish,

it was required to update as the setting:
MQTTBROKERNAME= mqtt.eu-latest.cumulocity.com
since the test tenant is on another instance.

I documented this in the documentation.

Regards Christof