MQTT Problem

I want to access the mqtt using this URL <my_tenant> and I get this msg

" not a WebSocket handshake request: missing upgrade "
what does it mean please ?
did I miss somthing ?

Thank you

Hi @Bayrem_Trabelsi

the URL <my_tenant> with port 443 is used for MQTT over WebSockets.
If you natively want to connect to MQTT you should use either with Port 1883 (non-ssl) or 8883 (ssl)
<my_tenant> with Port 1883 (non-ssl) or 8883 (ssl)

MQTT over websockets only:
<my_tenant> with Port 443 (ssl)

Find the full documentation here:

Thank you for your response
I used this URL :
I have been asked to select one of these certificates

each one of them led me to nothing

I guess you selected certificate based authentication via your MQTT client and it giving you all the certificates which you currently have in your cert store.
If you want to use certificate based authentication you have to follow the documentation Device integration using MQTT - Cumulocity IoT Guides.

Which MQTT Client you are using?

I would suggest to switch to user/password authentication to get it initially working as device certificate authentication requires quite some steps to get it working like creating a root CA cert, uploading the public key, signing a key, use the key in your mqtt client to authenticate etc.

I am using the MQTT and Cumulocity IoT for the first time…
Using this MQTT Software I can get Data such as “air pressure” but with a VPN Connection of my university.

the question is:
if it is Possible to get those data using Cumulocity?
What should I configure so I can make it possible to get those data using MQTT in Cumulocity?
I am not really sure how to start actually,
if you have any advice that will be helpful
Thank you in advance

Your last post is not 100% clear to me.
Cumulocity IoT is an IoT Platform where you integrate devices to build IoT solutions on top. So are you asking how to integrate your devices? Or are you asking how to get data out of Cumulocity?

MQTT in Cumulocity IoT is only for Device integration. So if you have a device you can integrate it using an agent like or other to integrate it to Cumulocity IoT. If this data is already integrated to your MQTT Broker you can use the following open-source component to map the data from your broker to Cumulocity IoT.

You need to have the microservice feature enable in your tenant.

Would be good if you could elaborate what you’re trying to do. Do you want to send sensor data towards the platform? Or you want to subscribe towards a sensor stream sent by Devices?

We want to create a dashboard where I can see the data that have been send from an MQTT Broker Mosquitto.
the Broker is installed within a secured Network and I can get those data only if I establish a VPN Connection.
We are using ThingsBoard as an open Source IoT-Platform, which have been installed on a server within the same secured network, to get data from sensors like temperature, air pressure… and to create a dashboard to display the course of those data and a conditioning alarm and so on…
Now we want to do the same on Cumulocity the Cloud IoT Plattform, therefore we want to establish the communication between Cumulocity and the secured MQTT Broker.

Cumulocity IoT cannot overcome your network infrastructure setup when running in the cloud out-of-the-box.
So if you have a MQTT Broker running in a secured network you need either.

  1. An agent running in the same network, subscribing on the MQTT topics of your sensors and forwarding the data to Cumulocity IoT either via REST API or MQTT. This could be or a custom agent. All under the assumptions outgoing internet connections are allowed from your network.

  2. Run an isolated Cumulocity IoT Edge in your secured network. Here you can use the dynamic MQTT Mapper that 1. connects to your MQTT Broker 2. allows you to map your data to Cumulocity IoT Domain Model 3. Uses the API to ingest the mapped data to your Cumulocity IoT Edge instance

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.