WmUpgrade Utility for Wm601

Hi ,
Could anyone tell me where to find The WmUpgrade utility. I could only locate readme file for this utility at advantage site, which says the default locatoin of this utility is <webmethods6_home> /Upgrade/bin/wmupgrade"
.I didn’t find the same in our existing installation.

Thanks

I had this same problem. I ran the webMethods installer and selected the Upgrade Utility to install. From what I could tell the install worked. The shortcut to “webMethods Enterprise Upgrade Utility” was created but the executable " wmupgrade.exe" in <webmethods>\Upgrade\bin does not exist. I went to the download site in Advantage and do not see the upgrade utility either.

Note: I emailed the keymaster at webMethods to see if they know why this is not available for download yet (even though there was a posting in the webMethods Advantage Release Announcements indicating the upgrade utility is available)

Regards,

Wayne

All,

I successfully installed the Upgrade utility using the webMethods installer. I did not have the problem that you have both experienced. I did this install yesterday August 04, 2003 around 3:15 pm MST. Maybe there was a glitch getting the software onto the download site and I just happened to hit it at a time where they had it available? I would try your install again and see if you experience the same problem.

I’ve had some issues running it against some of my brokers, but that is for another thread.

Steve

Thanks Steve. It appears there are intermittent technical difficulties with this. The webMethods Keymaster recommended that I open a ticket with webMethods support (which I have done).

Stay tuned!

Wayne

Thanks for update Steven and Wayne. I am early waiting for the Enterprise Upgrade Utility tool.

Cheers,
Thota

Ok…I finally got the utility to install. I uninstalled the Upgrade Utility first, since the webMethods installer thought it was installed already. I ran the installer again and this time the upgrade executable was installed too. Not sure what the problem was.
The only difference is today I’m working from home and the installer is not going through my work proxy server. I’m not sure if this is significant or not…but it’s worth mentioning. I’ll report the news to webMethods support. If anyone finds a pattern to this problem please let us (and webMethods) know.

Regards,

Wayne

Hi All,

Finally downloaded the WM upgarde utility and worked out on a POC,i get the following errors when i try to deploy

File “upgrade\runtime\Wm4XCompatibilityServices.zip” not found
File “upgrade\runtime\WWmTransformationServices.zip” not found

any of you guys have faced the above errors…

Also add your comments on how efficient is the tool, does it real minimize your efforts in migrating or adds more complexity…

i am trying to evaluate the tool for one of our migration projects…

Thanks
Ravi

Hi All,

Finally downloaded the WM upgarde utility and worked out on a POC,i get the following errors when i try to deploy

File “upgrade\runtime\Wm4XCompatibilityServices.zip” not found
File “upgrade\runtime\WWmTransformationServices.zip” not found

any of you guys have faced the above errors…

Also add your comments on how efficient is the tool, does it real minimize your efforts in migrating or adds more complexity…

i am trying to evaluate the tool for one of our migration projects…

Thanks

hi All,

I have installed WM upgrade utility form WM 6.1 installer successfully on a machine in a network.
Now when I am trying to connect to a broker of WM4.1.1 installed on a different machine (port 6335)in the same network its not able to connect and throwing me an error saying "TIME OUT”. Where as the upgrade utility is successfully able to connect to the broker of WM6.1 installed on port 6100 on the very same machine on which WM4.1.1 is installed.

Could you people please help me out with a solution of how to connect to the broker of WM4.1.1.

Regards,
Puneet Saxena

Hi Puneet,

i believe you are able to use other tools from the machine that runs with Upgrade util and connect to WM4.1.1? I am able to use it with a Broker Server 5.0 without any issue.

Did you get any solution to this error?

Hi chirag,
Thanx for the reply…I have tried to connect 4.1.1 through developer and I was able to do that, but I have not been able to connect to 4.1.1 using the upgrade tool till now.
I have installed 5.0 broker of webmethods and the rest of the components belong to 4.1.1 webmethods and now I am able to connect to it and presently trying to figure out a way of how to use the upgrade tool for upgrading 4.1.1.

Inputs are invited.

Regards,
Puneet Saxena

hi,
i migrated code from 4.x to 6.x , In 4.x there was a notification adapter, when i migrated to 6.x it created a polling notification in JDBC adapter. when i tried to enable the notification i get this error shown below.

[ART.116.3038] Adapter Runtime (Notification): Error in Notification Callback:enableCallback notification IntegrationServer0.Notifier_ATC:pq__notificationNotifierATC_11a0b18jjaInsertService.
[ADA.1.316] Cannot execute the SQL statement “CREATE SEQUENCE WMSnotification__Notifier_ATC_BNba2hyen ORDER”. "
(42000/972) ORA-00972: identifier is too long
"
ORA-00972: identifier is too long

the name was created by the Upgrade utility tool.
If any one got this error before… send me solution

Hi Amarnath,

Oracle imposes a 30 character limit on names of sequences (DB2 limits it at fewer than 30), which is why webmethods is unable to create the sequence.

If you notification was working correctly with 4.x, it could be either because Webmethods 4.6 might not have been adding the unique key (BNba2hyen in your case) to the BaseName, or your database version might have been different (something that allowed sequence names upto 39 characters).

PB

The solution to this problem could be to just change the base name to a shorter version, so that the overall length of the sequence name is less than or equal to 30 characters. The sequence name shows up on the same screen as the base name input box when you edit the notification through the Developer.