WmTNWeb package is empty

Is there a way to use services that are in the WmTNWeb package for webMethods 7.1.3? I can find them via search, but keep getting this error: “[ITD.0024.0001] Cannot access wm.tnweb.wrapper:getUserGroups’ without List ACL privileges”.
I’ve tried to change ACL for package itself and reload it afterwards, but nothing helps. Please let me know if there is way to enable it or if there is other way to get groups for Active Directory account?

Hi Juris,

first of all WmTNWeb package is considered deprecated and has been removed meanwhile in wM 8.2 and newer.
MWS TN UI should be used instead.

Try to replace services you are using from WmTNWeb with services from WmTN.
See TN Built-In Services guide for further informations.
Most liekly you will the appropriate services under wm.tn.profile:*

Regarding the ACL issue:

  • login in to your database schema used for IS Internal component with an external db client.
  • In the table IS_DATASTORE add a new row with the following content:
  • DATASTORE_ID: choose next number
  • STORAGE_CONTEXT: webforms
  • STORAGE_KEY: test
  • CTRL_INSERT_DT: 26.10.12 15:03:14 (current timestamp using sample format)
  • the other fields remain empty.
  • commit
  • restart IS.
    The added row can be removed afterwards.
    There should be an additional row for STORAGE_CONTEXT=webforms with STORAGE_KEY=(internal_all).
    After that the Services in the package WmTNWeb should accessible

This is due to a bug in the WmTNWeb package.

Additionally check your ACL settings in IS and/or MWS (i.e. Roles) if your user is member of “TN Administrators” and/or “TN Users”.


Hi ,

I am getting the same error.

[ITD.0024.0001] Cannot access ‘pub.client:soapRPC’ without List ACL privileges.

Could someone help me on this.


Hi Priya,

looks like a different issue as pub.client:soaRPC is not directly TN related.

Can you determine with which user are you trying to invoke pub.client:soapRPC?

Which version are you running on?


Hi Holger,

I am trying to invoke using ‘Administrator’ user.

Its 8.2 version.


pub.client:soapRPC service is deprecated and should not be used.

It is protected with WmPrivate ACL. Administrator user is not part of WmPrivate ACL that’s why you are receiving the error.


this only means that the service is not visible in the package navigator in designer, but it should be stull possible to execute it as the Execute ACL is Internal where Administrator is a member of.

You should use pub.client:soapClient instead of soapRPC or or soapHTTP.

If you really require to add soapRPC to your code, try the following:

  • add a pub.client:soapClient step in your code
  • modify the “service to invoke” in the properties panel of this step to pub.client:soapRPC.
  • save


SoapRPC was used for invoking an RPC/Encoded web service and soapHTTP for invoking a Document/Literal web service.
There are no direct replacement services, but in IS 7.1 with the introduction of Web Service Descriptors,
a new service pub.client:soapClient was introduced that would be used to invoke either style (RPC/Encoded or Document/Literal, or even the new RPC/Literal) web services going forward.

So while soapClient is not a direct replacement service for either of the other two old services, it kind of functionally replaces both.
by the way pub.client:soapRPC and pub.client:soapHTTP are still present and functional in the IS 9.9 for backward compatibility.

So, if you have migrated from IS 6.5 to the newer versions of the webMethods. Still the webservices developed in IS 6.5 should function properly.
But if you want to use pub.client:soapRPC service to create webservices on the newer versions of webMethods , then it is an obvious no-no. You should go with the webservice descriptor approach.

1 Like