[WM8.2] IS service wm.tn.archive:archive KO : "table or view does not exist"

I try to purge old TN data, but the service fails with that error :

Could not delete archived documents. (0) java.sql.SQLSyntaxErrorException: [sag-cjdbc42-0011][Oracle JDBC Driver][Oracle]ORA-00942: table or view does not exist (1) 

I checked the TN schema and it is fine, all the tables are there (with the ARCHIVE* tables).

Does anyone have an idea of what is missing ?

(I also tried the other service wm.tn.archive:extendedArchive, and got a null pointer exception)

Are you sure all the archive tables exists in the same DB that you are trying to run the tn:archive service?

Have you contacted your DBA also regarding this and I am sure they can troubleshoot and make sure nothing is missed on the schema accessing/privileges perspective etc…

If not please open a ticket with SAG support as a last option.

Yes the archive tables are in the same schema as the TN standard tables …

I do a ticket to SAG support.

OK…Did you run this with your DBA also?

I think its an issue with either wM accessing the schema/tables or privileges issue on the db side based on the error.

Please keep the forum posted with the SAG’s response.


Hi Simon,

Did you get any response from SAG support?

I am facing the same issue.

I tried running the service with user Administrator also, and it gave me the same error.


I would say work around or better option is run the TN archive/purge scripts via backend it self…I know you have to tune the scripts little bit to run it properly (take some DBA help if you are not a very SQL gig).