Webservice Consumer

Hello everyone,

First I would like to thank to whomever responds to this thread.

Issue at hand

I am calling a clients webservice (consumer) and running into an issue with the custom policy i have created and added it to the clients webserivce within webmethods. I removed the timestamp tag from the policy i copied from an exitsting webmethods policy. The isssue is the mustUnderstand tag needs to be removed from the copied policy i a modified. Can this be done?

webmethods version 9.7

Please check this empower article on the mustUnderstand attribute usage etc:

https://empower.softwareag.com/sl24sec/SecuredServices/KCFullTextASP/viewing/view.asp?KEY=111057-8883537&DSN=PIVOTAL&DST=TCD&HL=1&QUERY=mustUnderstand&SessionID=191998290

https://empower.softwareag.com/sl24sec/SecuredServices/KCFullTextASP/viewing/view.asp?KEY=098153-6662545&DSN=PIVOTAL&DST=TCD&HL=1&QUERY=mustUnderstand&SessionID=191998290

Some notes:
Software AG follows the ws-secuirty specs and that will send only mustunderstand=“1” in the security headers.

Otherwise, you have to intercept the request using soapHeader handlers and modify the headers that include mustunderstand=“0” which is against the specification.

HTH,
RMG

Hi RMG,

I would like to really thank you for looking into my issue, I am unsure at this point how to intercept the message, if you could help me out it would be greatly appreciated. I have attached a screen shot of the code that was generated when importing the clients WSDL.

Capture.PNG

IS your WSDL has the mustUnderstand attribute defined and are you using it in the policy?

HTH,
RMG

Hi RMG,

We are using within our policy.

Hi RMG,

Just wanted to mention thank you for looking at this with me, much appreciated. :smiley:

Hi – Is this been resolved, if not what is the current status.

Thanks,

Hello,

The issue at hand has not been resolved, any input or resolutions would very much appreciated.

Marlon – Is mustUnderstand attribute is mandatory for the recipient to process ? Can you please share your policy file by removing org specific details if possible.

Thanks,

Hi,

Once again I would like to thank you for looking at this for me. I beleive if we change the mustUnderstand tag to =0 rather than =1 the client system will accept the message.

I have attached the Policy for your review, once again thank you.
SCI_Username_Over_Transport_No_TimeStamp.txt (1.59 KB)

Marlon,

So did you try setting to 0 and test it?

If it works is that resolves your issue or may be I am missing any thing?

HTH,
RMG

Hi RMG,

Within the webservice endpoint (Alias) and i see the value within the pipeline messageAddressingProperties = false, but the data that the client rec’s has the mustunderstand still equaling 1. From reading the webservice developers guide this should be over written doesnt seem like the case. Also again I am thinking its something within the policy which is casuing this issue.

OK may be… Did you also open a ticket with SAG support on this issue yet?

HTH,
RMG

Hi RMG,

Yes, I have opened a ticket with SAG and its been open for a week.

Hi RMG,

anyway you can tell me the location of the soap logs? I enabled all the extended settings from a IS level but cannot seem to find them.

I believe you cannot see those SOAP logging in the IS logs but you may try to enable the Service auditing on the specific WS request services (that has connector/SOAP request calls) and that should give you some information you can view in the MWs–>Monitoring–>Services page.

HTH,
RMG

Marlon – We didn’t hear back from you for long time, can you please update on this thread.

Thanks,