Webservice connector issue

I was moving one of my Portlet application from 7.x to 8.2. This application has a webservice connector and the provider it calls on IS has the execute ACL set to anonymous, basically we do not pass any auth-parameters from CAF.

This worked properly and by default the requiresAuth for the webservice connector is set to false in 7.x. But this is not the case in 8.2, when i tried to call the same service through MWS, it throws an error ‘Access Denied’ error and the same error is logged on IS logs as well.
When i tried logging the requiresAuth, the default value in 8.2 is true, so i tried passing the credentials and it worked.

But i do not want to pass the credentails from CAF and i want my provider execute ACL to be anonymous.
What is the setting that i need to change to make this work with above configuration?

P.S: I tried setting the requiresAuth to false, in both property bindings of the webservice connector and web.xml of the portlet application and nothing worked.


‘requiresAuth’ is a deprecated property in 8.2 and is ignored. Using ‘basic’ auth with an empty username and password will give you the same result.

Hi Ron,
I’ll give it a try.
But the documentation on SAG site doesn’t say anything about this getting deprecated.

Can you please let me know where can i check this.


By default the auth type is basic auth and even if i set the username and password to blank or dont set them at all, my webservice throws an error Access Denied.
I tried using the auth type as METHOD_NONE, still it did not work.

The only way i could get it work is to pass the username and password when calling the webservice.

Did any one else face a similar issue?


Hi Sravan,

I have faced the same issue.
this was when webservices are anonymous, and connector has auth type as NONE.
We created a generic username and password at IS to pass with webservice and we set the auth type to basic.