Webmethods PortException

Hi All,

Webmethods port:5555,9999 being blocked by Firewall. When I am trying to log in into developer … its throwing message that Port Exception. I had tried in many ways.

Can Any body tell me how can we uninstall Webmethods through Command Line as I was not able to uninstall webmethods through ControlPanal. I had tried to uninstall to reinstall Webmethods to fix issue… PortException.

Please help me to fix issue.

Thanks & Regards,
Prakash.

Hi,

I am sure that you must be able to uninstall webMethods from control panel. If you still want to uninstall from command prompt follow the steps below:

Windows: Uninstall an Application from the Command Line

  1. Open a command prompt.

  2. Input WMIC and press Return. You will see a prompt that looks like this:

wmic:root\cli>

  1. At the new prompt, execute the following command:

product get name

This will generate a list of installed applications.

  1. At the prompt, execute the following command:

product where name="" call uninstall

where application name is the name of the program you wish to uninstall (use the exact name provided by the previously generated list).

For example, if I were wanting to uninstall Adobe Reader 9, my command would look like this:

product where name=“Adobe Reader 9” call uninstall

  1. When prompted, input y to confirm that you wish to uninstall the application and press Return.

Can you let me know your windows OS flavour?

Try the above steps and let me know if it has worked fine :slight_smile:

Hi Banu,

If you have access to the server/computer where Integration Server is installed you can go to Security >Ports add a new port (webMethods/HTTP), make it the primary and select the WmRoot package. This way you can access Integration Server in other port different that the default port without doing any uninstallation task.

If you still want to uninstall it you can do it from Control Panel without problems.

If you continue having problems accessing Integration Server from Developer please post the complete error message to fully understand what is happening or contact your system administrator to figure out why Integration Server is being block.

Regards

Hi,

Yes. As Douglas suggested you can have your own primary port created (make sure it refers to WmRoot pkg) and you can access IS and developer from that port.

Try the steps that we suggested if not keep posting we can see what other experts suggest.