webMethods Monitor - Remove data from archive database

Hi,

I have successfully set up webmethods monitor to archive the audit data older than 100 days.

But I would also like to delete data from the archive database older than 200 days. Does webMethods support this functionality?

Thanks in advance…

check the service:
wm.tn.archive:archive
wm.tn.archive:extendedArchive
they both have parameter:
deleteAfterDays
deletionType
which you can use to control deletion.

Thanks for the reply. Those services are used to archive TN data. Monitor is used to archive the audit logs.

I found a temporary solution.
The stored procedures used to perform the archive operations has truncate table command for some of the tables. My issue was it wasn’t truncating WMERROR and WMSESSION. So I updated the stored procedure for server data archive to truncate these dates before it inserts the archived data.
May not be the best idea, but no other option at the moment.

which Version of wM are we talking about?

Archiving mechanism has changed between 6.x and 7.x and newer.

Please check for DCC/DBS-Fixes as well as Monitor-Fixes as there might corrections for this.

Regards,
Holger

We are using version 9.

Perhaps things have changed recently, but typically once the data is in the archive tables, it’s your responsibility to clean it up from there. Having said this, the archive database is almost exactly like the real Production database so it shouldn’t be too difficult to configure the archive scripts to run against the actual archive database using the DELETE option.

Percio

The stored procedures for archiving the data from IS Core audit tables and process audit tables are in Archiving schema.

You can check table operation_log in this schema to see the error. The error happens sometimes because grants are needed for tables in IS core audit schema to be accessible from Archiving schema. Also you would need to check paramters table in Archiving schema to make sure all the parameters are configured properly and that it has been set to DELETE and not ARCHIVE.

Thanks,
Saurabh