webMethods Messaging subsystem was not initialized

The webMethods Messaging subsystem was not initialized.

We have developed a new 9.8 server (DEV) and installed IS and broker components.

while I am trying to configure the Broker Messaging in IS console below error occured in IS 9.8 Version. Please assist on this issue.

class com.wm.app.b2b.server.ServiceException
[ISS.0153.9012] The webMethods Messaging subsystem was not initialized. No webMethods Messaging features are available. Attached the screenshot.

No worries, its a known issue to me, modify dispatch.cnf and change all “-1” to “0”.

Hope you know where dispatch.cnf file exists?

hey … we have tried this option already but no luck…I see no “-1” at all in dispatch.cnf however.

Please let me know an alternative solution

You may also delete the dispatch.cnf file from config after backup and then start the IS.

Let me know the results.

Share me the location of dispatch.cnf file where you actually located?

Already done this… but no luck as i said

Did you try the dispatch file from backup i.e, <IS_Instance_Name>/config/backup

Looks strange to me as it worked for me in the past :slight_smile:

Nevertheless attach your server.log for further analysis.

I am facing the same issue in webMethods Mediator version 9.12. I tried to uninstall and then reinstall the server, but the same thing is happening again. Have you guys managed to fix this issue? Please, can you share any suggestions? Thanks in advance!

I found the solution. The sw license keys provided to me did not have permissions to configure the Messaging configuration, so this explains the issue. It would have been nice if the option to configure the Messaging would have been greyed out or removed based on what the sw license allows, so we would not be lead (or misled) to believe the feature was corrupted. Next time, check the license key more thoroughly before! :slight_smile: