webMethods - B2B Administration Access Denied - Configuring Trading Network

Hi,

My name is Manju and i have been working on webmethods since 12 months. And currently i have installed the TRAIL version of webmethods(9.8) and i was working on the component ‘TN’. It’s been quite few hours, i did all the possible work around i could think off for configuring TN, but still i am getting the following errors, can anyone please do help me out.

I have logged in by the username: “Administrator” and password: “manage” and the database installed is Oracle(which is working just fine) and i am not sure about the “roles” and “users” permissions as i tried all the combinations i could think off, even giving the permissions from “sysadmin”, but nothing is helping me out.

My email id is : mkm3621@gmail.com.


Manju,

Thanks for your information :slight_smile:

Check and try below:

You should configure your TN under Administration > My webMethods > System Settings > TN Servers

Did you run the TN components/products using DCC post your installation?

Hi Mahesh,

On the very first note, thank you so much for replying back :); I never expected any reply as such, as this was my very first post on webMethods & i am glad that you are helping me out to reply.

Having said that,

  1. About the dbConfigurator, i am very well aware in 8.x version, but i am not sure how to perform that in 9.8 as I do know that the procedure has been completely changed. - So, i did not perform that. But in the IS page i can very well see it is been already connected

  2. Now, as a part of the 2nd question, i have already done that, please do find the attached screenshot.

Hope you would help me on this :slight_smile:


Ok I see in your screen shots that JDBC pools for TN are already configured. But Administration > My webMethods > System Settings > TN Servers does not match with mine.

Look at the screen shot below: I do-not have any roles specified.

Well ideally,

The screenshot / configuration, what you had shown was exactly the same, when i initially configured it; But it still did not work out.
So i did add an extra roles or additions to it, so that, assuming it may work out. But it did not.

Anyways, do you have any idea how to run the dbConfigurator? And in which part of webMethods i can locate it?

I will try that as well.

Please guide.

Open DCC and refer the screen shot. Make sure you fill other details which are not show in snap shot.

Are you on free trial or licensed one?

Hi Mahesh,

It is a licensed one & as you mentioned, i did configure using the DBConfigurator for MWS Component, TN Database Component & TNArchive Component. Infact I did create the tablescpace for all products.

But still the same issue, “Access Denied”

I have a question on the screenshot below. There is an option called as Central user management = “Not Configured” on the top left. Do we need to configure that as well?

Hi Mahesh,

I also wanted to clarify this;

The database that i am running is Oracle & i have created a user by name: dbadmin & the user dbadmin was used in the dbConfigurator to create all the components.

This is really killing me out. Not sure why this is bugging a lot. I am tired and exhausted in figuring out the solution for it.

Don’t worry be happy. We will try and fix it tomorrow.

Hi Mahesh,

I am attaching couple of screenshots, which might help you in deciding the issues i am facing more closely.



Also do find these.



Make sure the below items are checked:

1> Go to Settings > Resources ->Single Sign-On with My webMethods Server
MWS SAML Resolver URL http://localhost:8585/services/SAML

2> Go to Security > User Management -> Central User Management Configured

3> Go to WmMonitor home page and check the settings are correct

4> Restart the MWS with IS up and running.

5> Restart IS and retry the access from MWS

Contact me on my email lets have a discussion.

HI Mahesh,

I did reply to your email. Please do let me know if you where able to receive the mail?

As discussed, Central User Management was not Configured. But JDBC pools where already set-up for Central Users .

Restarting IS and then accessing the MWS fixed the issue by which Central User Management=Configured.

1 Like

Hi Mahesh,

You where absolutely correct, after restarting the IS, it did work fine :slight_smile:

Thanks a ton for your effort and taking the pain in helping a webmethods seeker :slight_smile:

Will bug you / consult more for expert advices :slight_smile:

Ok, Thanks :slight_smile: