validation error - not sure where to look

I had a document fail yesterday within the conversationmanager with a validation error:

2006-05-11 11:01:26 EDT com.wm.lang.flow.FlowException:ip.util:validatePayload(): Error trapped in service wm.ip.util:validatePayload
[ESIPRT.000000.000020] Error: java.lang.NullPointerException
[ESIPRT.000000.000027] Occured at: 2006/05/11 11:01:26.359
[ESIPRT.000000.000021] Occured at: {0}
[ESIPRT.000000.000021] wm.ip.util:validatePayload

I checked the document against the dtd and it validated just fine. Is there anywhere else that I can look that might tell me the cause of this error?



What version of IS / Trading Networks are you using? Is this a new document type / partner / processing rule?


Version 4.6.

No, this wasn’t a new document type or new trading partner. That is what is so confusing.


Did the same document type(RNO PIP) working before??What is the PIP type? Any changes made in your RN module or services??


Yes, the same document has been working for quite awhile now. It was a ChemXml OrderCreate V2.0.1. We also had some come through right after the doc that threw the error and they worked just fine.

Every thing working fine but only during that particular document tranmission time.Did you tried reprocessing the failed OrderCreate?Did preamble,service headers for this OC201 processed successfully?

My bet is some mandatory element/special chars in the payload might be messing up the XML during its validation.