Using OCI driver from db Administrator

Hi - Has anyone been able to connect to Oracle9i with the JDBC OCI driver from an HP-UX 11 based Integration Server 4.6? I am testing this on wM Database Administrator. There’s no problem connecting to Oracle with the JDBC thin driver, it’s just the OCI “fat” driver that’s giving me problems. Here are the connection parameters:

dbUrl: jdbc:oracle:oci9:@ORCL_SID
dbDriver: oracle.jdbc.driver.OracleDriver

I’ve also tried “oci” and “oci8” in the dbUrl string above but none of these work either. I get an “Invalid Oracle URL” error.

I have installed the Oracle client on my calling IS client, set the LD_LIBRARY_PATH, updated CLASSPATH to include classes12.jar, and added an entry for ORCL_SID in my tnsnames.ora

Any help would be appreciated. Thanks.

We had the same problem when we switched from thin to OCI.
Our fix was to use the fully qualified TNS entry.

Try that. It should work if everything else is configured properly.

Good luck.


Hi Curtis - Well, I’m glad to see that it’s possible. I have tried your suggestion and it’s not working for me. It has to be something with my enviroment/config. To help me diagnose it, I hope you don’t mind if I ask some questions.

Was your IS running on a Windows or Unix plaftorm? Our IS is on HP-UX 11. If Unix, which vendor & version? On the backend, do you have Oracle8i or 9i? Regarding the ocijdbc library file, what’s the library filename and how does IS know where to look for it? I’m using libocijdbc9.a with “oci8” in my dbUrl connection string as you had recommended. In this case, the error I get is “Could not connect: Link Error: no ocijdbc9 in java.library.path”. Incidentally, if I use “oci9” in the dbUrl, I get “Invalid Oracle URL”.

Rajesh Vasisht

Hello friends,

We are also getting “no ocijdbc9 in java.library.path” when i configure and enable jdbc connection. We are using IS in HP-UX. Also i have set required LD_LIBRARY_PATH. I am not understanding why this error is coming. Can anyone guide me to configure jdbc connection for OCI driver in HP-UX?

Thanks and regards,

I had a similar issue and was able to trace the problem back to an issue with the LD_LIBRARY_PATH setting.


on the otherside you can try to use the JDBC-Thin Drivers for Oracle 10g, which solve most of the issues which were ot working with the old thin drivers resulting in a requirement to use OCI drivers.

We have currently a 9i R2 running on HP-UX with IS 6.1 running on HP-UX and we don�t have any problems with our connectivity to the database with thin drivers.

We are currently using Thin Driver versions (migrating to

Newest version available is

The thin drivers are backward compatible between 10g and 9i R2, but should be backward compatible with all other 8i (starting with 8.1.7) and 9i versions as well.

Check Oracle TechNet for further informations and for downloads of the drivers: