Unknown Service exception

Hi,

I have written a simple java service which connects to a given list of ISs(given as input) with the username and password provided(also being given as input) and am using

actionOutput = Service.doInvoke( “wm.server.services”, “serviceDelete”, input ); to delete a service on all the ISs.

flow service name picked at run time and creating an IData object -
IData input = IDataFactory.create();
IDataCursor inputCursor = input.getCursor();
IDataUtil.put( inputCursor, “service”, actionService ); actionService— service that is to be deleted.

when i run this service it successfully deletes the flow service on the same IS, but throws unknown service exception while deleting on other IS.

Can anyone suggest what the problem might be ?

Thanks,
Sachin

Can you share the source code with the error screen shot…

Also check the error log or server log for error dump if you see anything there…

You have to use pub.remote:invoke (* services) when dealing with another IS (IS to IS) as your code works with current IS session only.

HTH,
RMG

@Sachin,
I remember in past I have updated the same information in the below thread:

http://tech.forums.softwareag.com/techjforum/posts/list/53186.page#191690

removing the code for safety

Can you also provide the information as how you are passing the inputs… may be screen shot showing all the inputs

Attached is the image file of the inputs

It worked and am able to make it work for all the servers.

just changed to

actionOutput = con.invoke( “wm.server.services”, “serviceDelete”, input );

from

actionOutput = Service.doInvoke( “wm.server.services”, “serviceDelete”, input );

Thanks guys ! for your valuable feedback.

Great… was checking on the same… :slight_smile:

Last question… can you share the input data for the input fields… you can save the input data and attach the same…